on request #0, error: Connection timed out!

Discussion in 'Bug Reports' started by adriatic, Jan 1, 2008.

  1. adriatic

    adriatic Member

    If I upgrade to 3.3.3 my php application causes a 503 error. When I switch back to 3.2.4 the very same application works flawlessly. How is it? Thanks!
  2. mistwang

    mistwang LiteSpeed Staff

    Please check stderr.log for php startup errors, either missing library or bad php configuration. Fix those errors, it will work fine with 3.3.3
  3. adriatic

    adriatic Member

    Hello, thank you for your reply.

    I deleted the existing "stderror.log" and the "error.log" files, and then switched back to 3.3.3 (from 3.2.4). I still get a 503 error when accessing the site. The content of the "stderror.log" doesn't show any PHP-related error (see: http://pastie.caboo.se/133848 ), while the error.log content is this one: http://pastie.caboo.se/133849

    Any hints will be appreciated. Thank you!
  4. adriatic

    adriatic Member

    Hello, please let me know if you need additional debug info on my end. At the time being I'm running the site having switched back to 3.2.4. Thanks!
  5. mistwang

    mistwang LiteSpeed Staff

    Please try sudo -u nobody /opt/lsws/fcgi-bin/lshphp -i, it should show some warning/errors.
  6. adriatic

    adriatic Member

    I compiled PHP from the LSWS web interface and it went well with the default parameters proposed by the admin user interface php-compilation form. My "opt/lsws/fcgi-bin/" directory contains the following files:

    -r-xr-xr-x 1 root root 3317 Dec 30 23:09 lsperld.fpl
    -r-xr-xr-x 1 nobody nobody 1878016 Oct 23 2006 lsphp
    lrwxrwxrwx 1 root nobody 13 Jan 1 01:44 lsphp5 -> ./lsphp-5.2.5
    -rwxr-xr-x 1 root nobody 15697031 Jan 1 01:44 lsphp-5.2.5
    -r-xr-xr-x 1 root root 651 Dec 30 23:09 RailsRunner.rb

    Issuing the "./lsphp-5.2.5 -i | more" command I get a lot of informations but not warnings or error (let me know if you need to examine the output and I can send it privately). I issued the same command to "lsphp" (I had to make it exacecutale) and it reavelead to be a php 4 executable, which showed some errors, but I suppose I'm using php5 at the moment.

    What do you suggest to do? Thanks.
  7. mistwang

    mistwang LiteSpeed Staff

    check the lsphp or lsphp5 external app configuration to make sure the right executable has been used.
    Also always use "sudo -u <non_root_user_name> ./lsphp... -i" to check it, sometimes there are permission problem which does not exist for root user.
  8. adriatic

    adriatic Member

    Solved! :)

    What happened:

    As suggested by mistwang, at first I made sure to use php5 in all places where it is requested (external app). I thus, finally, discovered an error in my application which clearly was missing a function used to call a mysql database (mysql_connect). At this point I noticed that php4 was compiled (by default) with the mysql switch, while php5 is compiled (by default, through the LSWS admin interface) with the mysqli one. I thus recompiled php5 too with the mysql switch and everything worked again. Probably the 3.2.4 configuration was linked to the use of php4 while the 3.3.3 was linket to the use of php5 and since the mysql compilation switch was missing this was the reason of the issues I encountered.

    All is well what ends well ...

Share This Page