Opencart 2.3.0.2 + Journal2 Theme + Pagespeed

#1
Good evening I encounter a small problem on our site (https://www.aquamagasin.com)

If you want to place an order, order / login / billing information / button Continue button continue does not load when you click on it. It mill but it does not go to the next step.

Do you have any idea where this may come from?

For information, in Journal 2 we also use the complete functions Minifier and Cache Modules ---> Is compatible with Litespeed and cumulative pagespeed?

Thanks for your help
 

Pong

Well-Known Member
Staff member
#3
LiteSpeed cache should normally have no impact on your order/shopping cart since it won't cache it. Please try to disable litespeed cache, is it ok to place an order?
 
#4
I think I found the cause of my problems. I had activated in the module opencart / LiteSpeed Cache Settings function "LiteSpeed ESI Feature" out there it seems that it is it that is not compatible (Note:
OpenLiteSpeed does not support ESI functionality.) Strange even though this feature is present in the Opencart module.

I have a few questions to ask you to understand how it works:

1 - I do not understand why in the header, once I activate LiteSpeed I find "x-lsadc-cache: hit" and not "X-LiteSpeed-Cache: hit"?

2 - Is there any indication to use mod_headers protection with Litespeed? As :

- Header set X-XSS-Protection "1; mode = block"
- Header always append X-Frame-Options SAMEORIGIN
- Header set X-Content-Type-Options: "nosniff"
- Header always set Strict-Transport-Security "max-age = 15552001; includeSubDomains;"

3 - When I turn on Litespeed and check the http compression state, it is no longer active, while Litespeed disabled HTTP compression is active (https://www.whatsmyip.org/http-compression-test /? url = aHR0cHM6Ly93d3cuYXF1YW1hZ2FzaW4uY29t)

Thank you for your help and answers.
 

Pong

Well-Known Member
Staff member
#5
Before answering your questions, just to clarify: are you using openlitespeed and which version are you using(seems yes since you mentioned, but this forum is for LiteSpeed Enterprise, openlitespeed forum is forum.openlitespeed.org) ? second question is : do you use LiteSpeed ADC or just openlitespeed or LiteSpeed Enterprise only? "x-lsadc-cache: hit" should be header from ADC, not from OpenLiteSpeed or LiteSpeed Enterprise.
 
#6

Attachments

#7
Here is the response of my hebéregeur concerning LSADC.

"... For Hello,

This is normal, LSADC is the solution we use on our side, it is for this reason that it is he who is visible.

By cons, it should have been visible from the start because we do not use litespeed directly.

From your point of view, in terms of use, it does not change anything for you by cons. LSADC has the same cache as litespeed but is more flexible, that's why we use it ... "
 

Pong

Well-Known Member
Staff member
#8
seems now more clear, if you are just a shared hosting account with your hosting company, for any technical questions, better ask them. If you have a VPS and control everything by yourself, then you will have more control
 
Top