Path Does Not Exist

Discussion in 'Install/Configuration' started by zoom, Apr 13, 2007.

  1. zoom

    zoom Well-Known Member

    I just downloaded and installed the latest version of litespeed and I seem to be having a problem when setting up a new virtual host. I've specficied the Virtual Host Root to be /webs/ . However, when I enter the following for my DocumentRoot $VH_ROOT/html/ the server replies with:

    *path $VH_ROOT/html does not exist. Please create manually.

    I've double check the path and it's correct. The permissions on the path are the same as the web server and still no joy. Did I miss something? Any idea?
  2. mistwang

    mistwang LiteSpeed Staff

    I guess it should be a permission problem if the directory already exist.
    You can try change $VH_ROOT/html to "/webs/", see if it will help.
  3. zoom

    zoom Well-Known Member


    It must be a bug. I decided to continue with the configuration and populate the External Apps and Script Handler sections. After saving each of those I decided to go back and try entering the Document Root $VH_ROOT/html/ again . Too my surprise it worked.. Strange.. (permissions are fine).

    I was able to re-create the problem every time for a new virtual host. Resolving it by simply adding the External Apps sections and then returning to the "General" section and enter the Document Root information again.

    Note: Entering the exact path as you stated /webs/ works without any problems.
  4. mistwang

    mistwang LiteSpeed Staff

    OK, thanks. We will investigate.

Share This Page