permissions issue

Discussion in 'General' started by felosi, Aug 22, 2008.

  1. felosi

    felosi Well-Known Member

    I had a permission issue with lsws reading 000 files. I tried everything couldn't find what was the issue. I looked in litespeed admin and seen teh file access settings, I first tried to set it to the 0004 as described, didnt work so I changed it to an actual chmod setting of 644 and its now working like its supposed to

    It only happened on one server, what in the world would cause this?
  2. felosi

    felosi Well-Known Member

    Well I found the issue. In the File Access settings they are all set to 000 default. Now the thing is all my other servers are like this as well but they must not read that. I guess this last server DID read that config and served all 000 files

    Why is it default at 000? If alny server read that config (dont know how or why, but I had one that did) then it would too server all files with 000.

    A change of 0004 on this problem server fixed the issue.

    So this very well may be something that needs to be addressed.
  3. mistwang

    mistwang LiteSpeed Staff

    I think it is a server permission configuration issue. You can try

    sudo -u <user_that_lshttpd_run_as> cat <a_file_with_000_permission>

    if above command does not end up with a permission denied, it is a permission configuration issue.

    Maybe something related to role based access control in SELinux
  4. felosi

    felosi Well-Known Member

    no i promise only litespeed was reading those files. Changing the config in litespeed admin for minmum perms fixed it. Actually if all systems were to read that config in litespeed they would read 000 files as well. I just happend to have a server read that config and was therefore reading 000 files. Changing that config to 0004 fixed it.

    I doublechecked eveyrthing else, its not a server issue. Any other process or user will get access denied. I checked that first thing. It was just that server was reading that in litespeed admin. It is default 000. Not sure why this server was reading that config in litespeed but it did and the server was running with a minumum readable file as 000. Changing that number in litespeed admin to 0004 was the answer as I said above.
    Last edited: Aug 25, 2008

Share This Page