php 4.4.7 + curl, what did I do wrong?

Discussion in 'PHP' started by aww, May 10, 2007.

  1. aww

    aww Well-Known Member

    While I am still trying to figure out what I messed up with the old lsphp which I cannot get back online I thought I would post my attempt at php 4.4.7 and see if there is anything obvious as to why it seemed to build but threw errors on start:

    first I pulled down what I thought I needed and unpacked
    cd /
    rm -rf php-4.4.7
    tar zvxf php-4.4.7.tar.gz
    cd php-4.4.7/sapi
    tar zvxf php-litespeed-3.1.tgz
    tar zvxf curl-7.16.2.tar.gz
    then do the make
    cd ..
    touch ac*
    ./buildconf --force
    ./configure --with-litespeed --with-config-file-path=../php --with-mysql=/usr --with-zlib --with-zlib-dir=.. --with-gd --with-jpeg-dir=.. --with-png-dir=.. --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --enable-magic-quotes --with-openssl  --with-curl
    make install
    Now that configure line is a hybrid of my old cpanel/apache/phpinfo result where I didn't need all that junk but wanted a few things
    and litespeed's default phpinfo configure line
    resulting in
    (basically I wanted to add curl and threw in openssl too, note how I changed the --with-mysql=/usr per the wiki instructions and used the same path the old apache phpinfo shows)

    final steps
    cd /opt/lsws/fcgi-bin/
    mv lsphp lsphp.old
    cp /php-4.4.7/sapi/litespeed/php lsphp
    cd ..
    fcgi-bin/lsphp -v    <-- seems to pass, shows "(litespeed)"
    copy old default lsws php.ini to proper new conf place per wiki
    cp /opt/lsws/php/php.ini /opt/lsws/conf/php.ini
    server lsws restart
    and didn't work - lots of errors in the logs on startup

    Anything obviously wrong?
    Last edited: May 10, 2007
  2. aww

    aww Well-Known Member

    Happy discovery, I was able to build it using the above steps by dropping down to 4.4.6

    Runs without a hitch and with curl
    And because I went to 4.4.6 I could re-use your phpa install

    Oh and the step about the php.ini needing to be in conf is wrong, phpinfo says it's reading it from /php/php.ini
  3. mistwang

    mistwang LiteSpeed Staff

    The problem with 4.4.7 could be mismatched eAccelerator, when you upgrade PHP, you have to disable opcode cache first.

    We have made the eAccelerator for PHP 4.4.7 available.

Share This Page