PHP - Blank Pages

Discussion in 'Install/Configuration' started by Tristanlogd, Jan 5, 2006.

  1. Tristanlogd

    Tristanlogd New Member

    I have installed the Light Speed Webserver software, and have setup a basic virtual host pointing to my web directory, still learning how everything works, but Im having a problem.

    My site is built in PHP/MySQL, everytime I try to visit the site its just a blank page, Im not sure if this is because of PHP, or MySQL, but I tried an HTML page and it worked just fine. Any help would be appreciated, is there any sort of fix that will get rid of a blank page?

    Thanks :)
  2. xing

    xing LiteSpeed Staff

    Please provide the following so we can help you out:

    1) Access the .php page again in your browser.

    2) Paste the last few entries from your




    3) The log entries will tell a lot whether your php configuration for lsws is properly setup.
  3. Tristanlogd

    Tristanlogd New Member

    The error log shows no problem with php or anything, stderr.log contains nothing, heres the error log, nothing changes when I go to the php page, no errors or anything, just a plain blank page.

    I did a tail -f on the log to watch to see if anything was tacked on when I visited the php page, nothing happened.

    2006-01-05 22:52:40.477 [NOTICE] Loading LiteSpeed/2.1.9 Standard ...
    2006-01-05 22:52:40.580 [NOTICE] [ADMIN] server socket:
    2006-01-05 22:52:40.580 [NOTICE] Loading configuration from /opt/lsws/conf/httpd_config.xml ...
    2006-01-05 22:52:40.582 [INFO] old priority: 0, new priority: 0
    2006-01-05 22:52:40.582 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2006-01-05 22:52:40.893 [ERROR] HttpListener::start(): Can't listen at address lotgd: Address already in use!
    2006-01-05 22:52:40.893 [ERROR] HttpServer::addListener(lotgd) failed to create new listener
    2006-01-05 22:52:40.893 [ERROR] [config:server:listener:lotgd] failed to start listener on address *:80!
    2006-01-05 22:52:40.893 [NOTICE] The maximum number of file descriptor limit is set to 1024.
    2006-01-05 22:52:40.898 [NOTICE] [child: 5104] Successfully change current user to nobody
    2006-01-05 22:52:40.898 [NOTICE] [Child: 5104] Core dump is enabled.
    2006-01-05 22:52:40.899 [NOTICE] [Child: 5104] Setup swapping space...
    2006-01-05 22:52:40.899 [NOTICE] [Child: 5104] LiteSpeed/2.1.9 Standard starts successfully!
    2006-01-05 22:52:40.899 [NOTICE] [AutoRestarter] new child process with pid=5104 is forked!
    2006-01-05 22:52:40.999 [NOTICE] [AutoUpdate] Checking for new releases...
    2006-01-05 22:52:41.392 [INFO] [AutoUpdate] No new update.
  4. ts77

    ts77 Well-Known Member

    are you using the provided lsphp or did you set up your own php-fcgi-handler?
  5. mistwang

    mistwang LiteSpeed Staff

    I think you'd better reinstall LSWS, make the the PHP test page works, then add your own vhost configuration, please don't change the example vhost, create your own.

    You can turn on debug logging by changing "Debug Level" to "High".

    If your web application use any special PHP module, you need to build your own PHP binary.

Share This Page