PHP4 show in phpinfo ( not PHP5 )

Discussion in 'Install/Configuration' started by zep, Nov 5, 2008.

  1. zep

    zep Active Member

    I have installed the enterprise version of litespeed, and everything seemed good, but when I look at my phpinfo file, php4 show not php5. I recompiled successfully, tried again - no luck.

    So I deleted the isphp4 from the server -> settings, restarted,

    it still show php4!

    Any idea where I could have gone wrong?:confused:

  2. anewday

    anewday Moderator

    Did you set php5 for PHP in SCRIPT HANDLER?
  3. zep

    zep Active Member

    thanks for the reply :), yes isphp5 and litespeed server api is set in script handler at the server level
  4. mistwang

    mistwang LiteSpeed Staff

    You need build PHP5 binary either from web console, cPanel plugin, or manually.

    The executable should be named lsws/fcgi-bin/lsphp5, right now it is a symbolic link to lsws/fcgi-bin/lsphp4.
  5. zep

    zep Active Member

    Ok I did compile php from the litespeed web console, a couple times and restarted.

    I am building it again right now, and will check the log for any errors, then post back.

    Miststang, your always here, I really appreciate that ( and also one of the reasons Im running your enterprise version on 3 servers right now ):rolleyes:
  6. zep

    zep Active Member

    I found this in the build log.... a clue?:confused:

    checking for PHP prefix... /opt/lsws/lsphp5
    checking for PHP includes... -I/opt/lsws/lsphp5/include/php -I/opt/lsws/lsphp5/include/php/main -I/opt/lsws/lsphp5/include/php/TSRM -I/opt/lsws/lsphp5/include/php/Zend -I/opt/lsws/lsphp5/include/php/ext -I/opt/lsws/lsphp5/include/php/ext/date/lib
    checking for PHP extension directory... /opt/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20060613
    checking for PHP installed headers prefix... /opt/lsws/lsphp5/include/php
    checking for re2c... no
    configure: WARNING: You will need re2c 0.12.0 or later if you want to regenerate PHP parsers.

    Im going to yum install re2c and recompile php and see if that works out...
    Last edited: Nov 5, 2008
  7. zep

    zep Active Member

    no dice - Im open to suggestions...

    I also found a couple other lines that may be of some interest
    configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 2.2 2.3 (found: none).
    configure: warning: flex versions supported for regeneration of the Zend/PHP parsers: 2.5.4 (found: none)
    configure: warning: lemon versions supported for regeneration of libsqlite parsers: 1.0 (found: none).
    Last edited: Nov 5, 2008
  8. mistwang

    mistwang LiteSpeed Staff

    try "yum install bison flex lemon".
  9. zep

    zep Active Member

    I tried this, the error I get is

    Error unpacking rpm package bison - 2.3-4.fc8.x86_64
    error: unpacking of archive failed on file /usr/share/locale/id/LC_MESSAGES/;491233cc: cpio: mkdir

    I tried rebuilding php, and restarted.

    I dont knwo whats wrong, I havent had this issue before...
  10. zep

    zep Active Member

    I reinstalled litespeed and started over, everything is working now

  11. anewday

    anewday Moderator

    Seems it's caused by you moving the location of litespeed install?

Share This Page