Poor performance with CageFS and suEXEC daemon

Discussion in 'General' started by georgetasioulis, Sep 22, 2012.

  1. Hello,

    We recently changed our setup to use CageFS and run LSAPI as a suEXEC daemon, but we've seen a very noticeable decrease in page-to-page browsing load speeds.
    All our customer websites seem to load slower when browsing from page to page (when you're in the homepage of a website and click to another page, you have to wait, and then after 3-5 seconds, then other page comes). Below are our settings:

    === "Slow" performance ===
    + Configuration -> Server
    - General
    - CloudLinux = CageFS
    + Configuration -> Server
    - External App
    - LSAPI App (lsphp5)
    - Run on startup = suEXEC daemon

    But when Cloudlinux support is set back to LVE, and suEXEC daemon is not used, speeds are back to normal and websites run fast again.

    === Fast performance ===
    + Configuration -> Server
    - General
    - CloudLinux = LVE
    + Configuration -> Server
    - External App
    - LSAPI App (lsphp5)
    - Run on startup = Yes

    I've tried to increase the I/O limit on CloudLinux LVE Manager (when in CageFS/suEXEC daemon mode), but this didn't help.

    Any idea what can cause this "hanging" between page loads?
  2. mistwang

    mistwang LiteSpeed Staff

    You can try suEXEC daemon + LVE, see if any performance issue.
    We need to narrow down the issue is caused by CageFS or suEXEC daemon.
  3. I just tried all possible combinations and it looks like suEXEC daemon is the problem.

    When I have suEXEC daemon on, either with LVE or CageFS, I have this 2-3 second hanging between page loads. Page loading is super fast -when it starts- the problem is that it seems like it's hanging, waiting for a little bit, and then the page comes instantly.

    When running either LVE or CageFS mode, and Run on startup = Yes, the "hanging" problem is gone.

    It's not a *huge* deal, and maybe some will think it's ok, but for me knowing how my sites loaded two days ago, and seeing the difference when changing to suEXEC daemon, it's noticeable.

    I'm changing my settings to not use suEXEC daemon for now, and maybe have a look at it Monday morning. Have a nice weekend all!
  4. mistwang

    mistwang LiteSpeed Staff

    Please check error.log and stderr.log see if anything pop up.
    Also, enable "Debug Logging" to find out what happened, you can track related log entries by search your IP address.
  5. frederichoule

    frederichoule New Member

    I have the same problem, any fix?

Share This Page