problem with eAccelerator

Discussion in 'Install/Configuration' started by AviATic, Mar 24, 2013.

  1. AviATic

    AviATic Member

    i have compile php5.3.21 with eAccelerator all its ok i have added extension=... in php.ini but when i have restarted lsws he show me this.

    PHP Warning: Unknown(): Unable to load dynamic library '/usr/local/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20090626/' - /usr/local/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20090626/ undefined symbol: zend_function_dtor in Unknown on line 0

    i have search in google but i not find anything
    im in centos 5 32bit and
  2. NiteWave

    NiteWave Administrator

    I just compiled latest php 5.3.23 with eAccelerator(the version is without problem --- phpinfo() ok with eAccelerator section

    and it's centOS 5.8 32-bit.

    how did you compile php -- via admin console or easyApache then building matching php ? eAccelerator's version ?

    is there?
    #ls -al /usr/local/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20090626/
  3. AviATic

    AviATic Member

    i have compile php via admin console version ( i have kloxo panel and when i run this comand php -v he show me this

    PHP 5.2.17 (cli) (built: Dec 17 2012 18:16:56)
    Copyright (c) 1997-2010 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

    but this information of php installed with kloxo and when i open infophp.php he show me PHP Version 5.3.23 and Zend Engine v2.3.0, Copyright (c) 1998-2013 Zend Technologies
  4. NiteWave

    NiteWave Administrator

    please check
    #/usr/local/lsws/fcgi-bin/lsphp5 -i |head -20
  5. AviATic

    AviATic Member

    thank you for your reply, when i run this command he show me

    PHP Version => 5.3.23

    System => Linux x.x.xx-xxx.x.x.el5xen #1 SMP Tue Nov 3 17:53:4 7 EST 2009 i686
    Build Date => Mar 25 2013 21:31:16
    Configure Command => './configure' '--prefix=/usr/local/lsws/lsphp5' '--with-c url' '--with-zlib' '--with-gd' '--enable-shmop' '--enable-track-vars' '--enable- sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-magic-quotes' '--enable -mbstring' '--with-iconv' '--with-litespeed'
    Server API => LiteSpeed V6.1
    Virtual Directory Support => disabled
    Configuration File (php.ini) Path => /usr/local/lsws/lsphp5/lib
    Loaded Configuration File => (none)
    Scan this dir for additional .ini files => (none)
    Additional .ini files parsed => (none)
    PHP API => 20090626
    PHP Extension => 20090626
    Zend Extension => 220090626
    Zend Extension Build => API220090626,NTS
    PHP Extension Build => API20090626,NTS
    Debug Build => no
    Thread Safety => disabled
    Zend Memory Manager => enabled
  6. NiteWave

    NiteWave Administrator

    this is the reason --- you don't have a php.ini file

    for quick test, create
    /usr/local/lsws/lsphp5/lib/php.ini, add just 1 line:

    restart lsws, the error may disappear.

Share This Page