problem with vhost

Discussion in 'Install/Configuration' started by tafkae, Nov 30, 2011.

  1. tafkae

    tafkae Member


    I've successfully installed litespeed webserver with PHP and MySQL on my Debian Squeeze VPS.
    Actually I just have a problem configuring the vhosts, I'm running 2 domains on it, the PHP files are located at /var/www/domain/public_html/.
    The virtual host templates (I'm using "PHP_SuEXEC") are configured correctly, my problem is that the domains just show the "successfully installed litespeed" page (if I use my VPS IP instead of the real domain name in the PHP_SuEXEC config I can get one domain working).
    Maybe this is caused because I am not using anything in the "Virtual Hosts" tab as I deleted the "Default" vhost, could anyone c&p me the settings of the "Default" vhost (to configure the listeners)? Or does anyone have an idea why it doesn't work?

    Thanks a lot!

  2. webizen

    webizen Well-Known Member

    does listener map to those vhosts? you could re-install lsws to get default vhost back.
  3. tafkae

    tafkae Member

    I cant map then as I don't have a vhost (default removed)..

    How could I reinstall without loosing my compiled lsphp + config?
  4. webizen

    webizen Well-Known Member

    you will loose these settings once re-install.

    Did you instantiate the vhosts that created by template? Once did, the vhost will be available for listener mapping.

    Also, here is the settings for default vhost.

    Virtual Host Name: Default
    Virtual Host Root: $SERVER_ROOT/DEFAULT/
    Config File: $VH_ROOT/conf/vhconf.xml
    Max Keep-Alive Requests: 100
  5. tafkae

    tafkae Member

    I just cant get it working.. May someone have a look about my configs / lsws panel? Would be great!
  6. webizen

    webizen Well-Known Member

  7. webizen

    webizen Well-Known Member

    make sure you have index page such as index.php index.html in docroot.

Share This Page