Rails 503 Error

Discussion in 'Install/Configuration' started by persuses, Jun 7, 2008.

  1. persuses

    persuses New Member

    Changing Rails App (redmine) base url throws 503 error


    So I am trying to run a rails app (redmine) on my Ubuntu 8.04 server. Everything works fine when use random port, set up a listener/virtual host, and access redmine from "www.domain.com:randomport". I would like to move the app to "https://www.domain.com/redmine" (so port 443). So I created a listener (with ssl), created a context in my virtual host with a uri of "/redmine" and pointed it to the redmine folder.

    Well it almost worked. When I pointed my browser to "https://domain.com/redmine", I got redmine's 404 resource not found (so I know its pointing to the right application at least). Checking the rails app log file, it complained about the controller /redmine not existing, so its using the wrong base url, basically it thinks /redmine is the path to the controller.

    Ok, so I went to redmine's routes.rb file and the following to prepend "/redmine" to the front of all paths:
    map.connect 'redmine/:controller/:action/:id'
    After compiling and restarting the server, I now get a Litespeed 503 Service Unavailable and I notice this in my Litespeed error log:

    GET /redmine/ HTTP/1.1
    2008-06-06 23:56:52.476 [NOTICE] [] Redirect: #1, URL: /redmine/dispatch.lsapi
    2008-06-06 23:56:52.476 [NOTICE] [] oops! [B]503 Service Unavailable[/B]
    2008-06-06 23:56:52.476 [NOTICE] [] Content len: 0, Request line:
    Sigh, I've tried everything I can think of. I'm using LiteSpeed Standard 3.3.14

    I appreciate any help,
    Last edited: Jun 7, 2008

Share This Page