Rails staging environment

Discussion in 'Ruby/Rails' started by sfreiberg, Jan 29, 2008.

  1. sfreiberg

    sfreiberg Member

    I'm trying to get Rails running in the new staging mode and I get the following error:

    [config:server:rails] invalid value of <railsEnv>:2, use default=1

    In case this was dependent on the ruby-lsapi I upgraded that to 2.9. Any idea why this isn't working? This is the standard version of LiteSpeed. Our Enterprise versions only run in production mode so I haven't tried it there.

    By the way I'm sooo glad to see a staging mode so a big thanks!
  2. mistwang

    mistwang LiteSpeed Staff

    There is one more place need to be changed, so the default rails configuration does not take staging, will be fixed, just override the environment in the specific rails context configuration.
  3. sfreiberg

    sfreiberg Member

    I had it set in both places, but I had assumed that staging in LiteSpeed translated to test in Rails. Once I changed that in the database.yml file and renamed the test.rb file to staging.rb everything worked fine.

Share This Page