Remove query strings from static resources

#1
Hello
I use Wordpress for my website: https://den247.com/.
I installed Pluin Jetpack and LiteSpeed Cache.
But when I check with https://gtmetrix.com/, the query strings are not deleted.
My cache has been enabled. Remove Query Strings.
I have tried turning off the Query Strings from Jetpack and enabling the Litespeed cache CDN but it still does not work.
Do you have any way to help me?
thank you very much
 
Last edited by a moderator:

Pong

Well-Known Member
Staff member
#2
can you provide a detailed example of the query strings problem? Any URL for us to check? Why do you believe it was LSCache related?
 
#3
Pls check it for me
https://i0.wp.com/den247.com/wp-content/plugins/revslider/admin/assets/images/transparent.png?ssl=1

DB5F3B83-D1E2-450E-947B-8B168516F866.png
Thank you very much
 

Unique_Eric

Administrator
Staff member
#4
Hi @geckobin,
I just did some simple check from response header. From my browser I didnt see those QS until gtmetrix.
Those pages with QS also shows `x-nc: HIT`. So can you try purge your CDN cache then try it again? Or just turn off CDN plugin and see if issue gone.
 
#5
Hello
When I turn off the Jetpack plugin, it's gone. But if you disable the Jetpack plugin, you must adjust the image size in the CSS or HTML file. Therefore, I want to keep the Jetpack plugin
thank you very much
 

Pong

Well-Known Member
Staff member
#6
But if you disable the Jetpack plugin, you must adjust the image size in the CSS or HTML file
Can you clarify the above?
Do you use jetpack image optimization function?

seem you should check the problem with Jetpack support.
 
Top