[RESOLVED] cPanel + parked domains

Discussion in 'Bug Reports' started by xantra, Feb 24, 2010.

  1. xantra

    xantra Member

    I have installed the latest (4.0.13) litespeed on latest release version of cPanel (still in trial, I am looking at this option) but by now I have noticed one bigger issue: I cannot redirect domains with .htacces.
    When in cPanel I try to "manage redirection" and enter the domain, I get this error:

    domain.com is now being redirected to unchanged(Apache detected an error in the Rewrite config.

    /usr/local/apache/bin/httpd: line 17: /usr/local/lsws/logs/ap_cmd_param.log: Permission denied
    Syntax error on line 29 of /home/hosting/public_html/.htaccess.gV3iG2l9UL6n7WEH74AukWj0Ya_tusH0:
    RewriteRule: bad flag delimiters
    Please try again.)

    I find this rather irritating, since I can't/don't want to limit my customers in parked domains.
    Is there a solution for this? I found one thread with similar problem, and someone from your team said you will solve this problem, but as I can see, it's still not solved.

    Last edited by a moderator: Feb 25, 2010
  2. mistwang

    mistwang LiteSpeed Staff

    Pleaes try

    chmod a+w /usr/local/lsws/logs/ap_cmd_param.log

    from command line, then try update .htaccess again.
  3. xantra

    xantra Member

    Now this error is gone:
    but I still got the:
    Any idea?
  4. mistwang

    mistwang LiteSpeed Staff

    Please switch back to Apache, see if you get the same error.
    Looks like that there are some kind of syntax error with the rewrite rule. the error is from Apache.

    You can check the current .htaccess, there might be a syntax error on line 29 when user add a rewrite rule, when cPanel append something to it, the whole file is tested, and detected the error.
  5. xantra

    xantra Member

    I checked the .htaccess, it had a error in line 29 :)
    Thanks alot!

    Now another issue arised, but I will open another thread for it.

Share This Page