[RESOLVED] failed to open stream: Permission denied (Service.php)

Discussion in 'General' started by Cameo, Jan 23, 2010.

  1. Cameo

    Cameo Member

    Any help with the following errors from the general server log would be appreciated:

    [STDERR] PHP Warning: filemtime() [<a href='function.filemtime'>function.filemtime</a>]: Stat failed for /tmp/lshttpd/.status (errno=13 - Permission denied) in /opt/lsws/admin/html.4.0.12/classes/ws/Service.php on line 33

    [STDERR] PHP Warning: fopen(/tmp/lshttpd/.status) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /opt/lsws/admin/html.4.0.12/classes/ws/Service.php on line 128
    2010-01-23 14:53:47.793

    [STDERR] PHP Warning: fopen(/tmp/lshttpd/lshttpd.pid) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /opt/lsws/admin/html.4.0.12/classes/ws/Service.php on line 70

    What owner:group and permissions should be set for these paths?
    Last edited by a moderator: Jan 27, 2010
  2. anewday

    anewday Moderator

    I think it's lsadmin
  3. mistwang

    mistwang LiteSpeed Staff

    what is the owner and permission mask for /tmp/lshttpd?
    ls -ld /tmp/lshttpd
  4. Cameo

    Cameo Member

    0710 apache:apache

    drwx--x--- 3 apache apache
  5. mistwang

    mistwang LiteSpeed Staff

    is "lsadm" a member of "apache" group?
    check /etc/group
    If not, add lsadm to "apache" group.
  6. Cameo

    Cameo Member


    Thank you! That solved it.

    It also took care of another annoyance we couldn't fix with the realtime stats being inaccessible after server restart:

  7. NiteWave

    NiteWave Administrator

    for 17347:
    what version of lsws? which platform? latest 4.0.12 may not have this issue any more.

    or check again, this old issue may relate to the new issue you just resolved. the old issue may disappear after you fix the new issue.
    Last edited: Jan 26, 2010
  8. Cameo

    Cameo Member

    Sorry, that's what I meant. The group issue (resolved above) fixed this problem too. Everything is well in LSWS land over here. Thanks!
  9. i am getting same error. failed to open stream: Permission denied

    i found this topic from google search.can someone explain how can i add lsadm group to my apache server? i need steps and commands.
  10. NiteWave

    NiteWave Administrator

    lsadm is created automatically by install.sh. if it's not created after installation, then something wrong. what's your OS version, 32-bit or 64-bit?

Share This Page