[Resolved] lscgid: execve():<<dir>> No such file or directory

Discussion in 'General' started by optize, Mar 27, 2010.

  1. optize

    optize Well-Known Member

    I'm getting that error when trying to view a simple 'hello world' perl script.

    stderr says:

    2010-03-27 10:51:36.323 [STDERR] lscgid: execve():/home/xx/public_html/cgi-bin/perl.cgi: No such file or directory

    However that file exists and permissions seems okay. If I switch back to Apache, I get some useful logs:

    [Sat Mar 27 10:46:08 2010] [error] [client ] suexec failure: could not open log file
    [Sat Mar 27 10:46:08 2010] [error] [client ] fopen: Permission denied
    [Sat Mar 27 10:46:08 2010] [error] [client ] Premature end of script headers: perl4.cgi

    2010-03-27 10:39:24.228 [STDERR] [2010-03-27 10:39:24 -0500] warn [whmredirect] User file '/var/cpanel/users/nobody' is empty or non-existent. at /usr/local/cpanel/Cpanel/Config/LoadCpUserFile.pm line 35
    Cpanel::Config::LoadCpUserFile::load('nobody') called at /usr/local/cpanel/Cpanel/Config/LoadCpUserFile.pm line 158
    Cpanel::Config::LoadCpUserFile::loadcpuserfile('nobody') called at /usr/local/cpanel/Cpanel/AcctUtils/Domain.pm line 16
    Cpanel::AcctUtils::Domain::getdomain('nobody') called at /usr/local/cpanel/Cpanel/Redirect.pm line 63
    Cpanel::Redirect::redirect('service', 'whm', 'ssl', 0) called at /usr/local/cpanel/cgi-sys/whmredirect.cgi line 11

    I tried it on another server and it works fine, so it's something with this server, I also have a open ticket in with cPanel.

    Another person here had the same error message and LS recommended increasing memory, but I don't think it's the same problem.
    Last edited by a moderator: Mar 28, 2010
  2. mistwang

    mistwang LiteSpeed Staff

    please check /usr/bin/perl permission.
  3. optize

    optize Well-Known Member

    Ended up being a windows carriage return;

    # ./perl4.cgi
    bash: ./perl4.cgi: /usr/bin/perl^M: bad interpreter: No such file or directory
  4. mistwang

    mistwang LiteSpeed Staff

    Yes, have to be careful when upload script from windows to Linux via ftp. must do it in ascii mode.

Share This Page