[RESOLVED] LSWS 4.0.13 - Signal 9's gone... Signal 15's new

Discussion in 'Bug Reports' started by MikeDVB, Feb 28, 2010.

  1. mistwang

    mistwang LiteSpeed Staff

    We are still working on it.

    In the mean time, you can try our wswatch.sh script. Update /usr/local/lsws/bin/wswatch.sh with bellow shell script.

    BASE_DIR=`dirname "$0"`
    cd "$BASE_DIR"
    while [ "1" -eq "1" ]; do
    if [ -f /tmp/lshttpd/lshttpd.pid ]; then
        kill -0 `cat /tmp/lshttpd/lshttpd.pid` 2>/dev/null
    if [ $ERR -ne 0 ]; then
        sleep 2
        if [ -f /tmp/lshttpd/lshttpd.pid ]; then
            kill -0 `cat /tmp/lshttpd/lshttpd.pid` 2>/dev/null
    if [ $ERR -ne 0 ]; then
        echo "$D: LSWS stopped, start LSWS." >> $BASE_DIR/../logs/error.log
    sleep 2
    and edit lsws/bin/lswsctrl script, uncomment

    at the beginning of the file. do
    ./lswsctrl stop
    ./lswsctrl start
    It will start lshttpd in 2 seconds if cPanel kills off LSWS.
  2. aww

    aww Well-Known Member

    okay, thanks, just did the changes and will watch this weekend to see if it helps

    my lsws location is under /opt/lsws btw, I guess you changed the default over time
  3. anewday

    anewday Moderator

    How did it go?
  4. aww

    aww Well-Known Member

    Oh sorry for the lack of updates, the above workaround works perfect, no more emails about signal 15s
  5. aww

    aww Well-Known Member

    Actually, you know what - with the 4.0.15 it's back

    Every few hours or so
    Would the upgrade have clobbered the old wswatch.sh or lsws/bin/lswsctrl ?
  6. MikeDVB

    MikeDVB Well-Known Member

    The newest .15 disabled wswatch by default as it was causing issues on cPanel servers when editing the httpd.conf (or at least, that's what it said in my support ticket).
  7. aww

    aww Well-Known Member

    I really hope they find a workaround for this soon, the sheer number of times it's happening is worrying me.

    Why is cpanel so anti-non-apache?
    Last edited: Jul 28, 2010
  8. mistwang

    mistwang LiteSpeed Staff

    Please download and try 4.0.16 release package, it should take care of the signal 9 issue. Will announce it tomorrow.
  9. aww

    aww Well-Known Member

    Ah, I noticed the new date on 4.0.16 yesterday and gave it a try and sure enough it did indeed stop the problem.

    Thank you!
  10. aww

    aww Well-Known Member

    I spoke too soon.

    Getting Signal 15's every 2 hours now on 4.0.16
  11. tachra

    tachra Member

    Me too
    web server with pid=1985 received unexpected signal=15, no core file is created. A new instance of web server will be started automatically!
  12. aww

    aww Well-Known Member

    Not positive yet, but I think they are gone again with the unpublished 4.0.17

    Nope, still there

    At [28/Aug/2010:15:03:31 -0400], web server with pid=26374 received unexpected signal=15, no core file is created. A new instance of web server will be started automatically!
  13. Tony

    Tony Well-Known Member

    I think the best solution to this problem is from someone from cPanel to actually provide documentation of cPanel's Apache logic. They are sending kills among other things at the Litespeed processes. Why I don't know but a lot of their Apache logic is hidden in compiled binaries now so without them providing a helping hand no one will know. It could be something as simple as them waiting 10 seconds then issuing kills at all processes still existing.

    This problem showed up when cPanel released 11.25 and unfortunately still is not fixed. Soon after 11.25 was released I tried contacting them about it. Unfortunately you talk to someone active on their forums they say make a ticket. The ticket people are unable to help provide such information. So I don't know where you'd go on this I've tried and failed as I don't have the connections to cPanel team it seems.
  14. aww

    aww Well-Known Member

    If cpanel wants to survive they really need to start working with vendors that use things other than Apache. There are now a dozen Apache replacements and a few of them like litespeed are too good to pass up.

    Fortunately my linux and CLI knowledge/experience has grown to the point where I might be able to give up cpanel entirely in a year or two, especially if they don't start playing nice with others.
  15. aww

    aww Well-Known Member

    Now I am periodically finding the webserver completely unresponsive.

    I have to do a service lsws restart to get it going.

    Whatever cpanel is doing is making it worse.

    Discovered WSWATCH was automatically commented out somehow again.

    Does the upgrade process replace wswatch.sh ? So I have to edit it after each update? (That's fine, I just need to know that.)
    Last edited: Sep 2, 2010
  16. Tony

    Tony Well-Known Member

    We reported a problem with it when we tried 4.0.15 and eventually it was completely disabled. It was causing the cPanel restart scripts to lock up.
  17. aww

    aww Well-Known Member


    Well I am using 4.0.17 (pre-release) and I think I re-enabled wswatch - and 18 hours later no lockups (or more importantly server stalls).

    However I do not see any notices in the error.log about it restarting anything, so maybe it's not even running.

    This is starting to become a serious problem as far as unreliability.
  18. mistwang

    mistwang LiteSpeed Staff

    wswatch may cause trouble for shared hosting environment which need to apply configuration changes frequently.
    For signal 15 issue, please send us the error log and lsws/logs/ap_cmd_param.log

Share This Page