[RESOLVED]Slow + Random Downloading


Well-Known Member
Trying to run Redmine using the Ruby LSAPI (suexec) and seeing some strange things. This copy of Litespeed does not run any control panel or anything like that uses lsws configs directly and all that.

So what happens is two people view it or just one person going through pages at a moderate rate and it starts asking to download the files at random. If it's not that the pages seem extremely slow. Tried upping the number of connections, removing max idle time everything makes no difference.

What is really strange is with a max connections of 5 real time stats only ever says there is 1 ruby external app. Checking the process list though there are two running.

So any idea's? Tried default configs tried tweaking from various posts seems to make no difference. It's almost like it refuses to use the other ruby processes except the original one.
Last edited by a moderator:


Well-Known Member
Upgrading to 4.0.12 resolved the random downloading issue and slowness. I still don't understand what is going on with the real time stats. Have none running but process list shows one. So it seems to always have one but based on tracing the process it never serves a single ruby request? A new one is spawned and serves the requests rather than the one running. Very strange


LiteSpeed Staff
Start a fresh ruby process is very expensive, so it is not a good idea to let ruby process die frequently. Instead, LiteSpeed will keep one ruby process running, when new request comes, it will fork a child process to serve the request, and the child process quit after idling for a while. When multiple request comes in at the same time, the parent ruby process can fork multiple ruby processes immediately to serve all requests. That's the reason why parent ruby process does not serve any request directly.


Well-Known Member
That makes sense I would not even have noticed that except for the other issues. 4.0.12 fixes things and now Ruby runs great :) No noted fixes for the issue we experienced but no big deal things some times get fixed inadvertly anyways.


Well-Known Member
Well 4.0.12 seems to have fixed the non SSL version but if we use SSL version we get prompted to download at random. I have no idea what causes it nothing in the logs as far as I can tell? It's very odd the only difference between non SSL and SSL is a different listener they share the same vhost. Any idea's?


Well-Known Member
Well the server runs fine besides the SSL. It also is doing exactly what it did in 4.0.11 when SSL was not even being used. Upgraded to 4.0.12 and the non SSL version started working fine. This is what we get prompted to download:

HTTP/1.1 200 OK
Content-Encoding: gzip
Vary: Accept-Encoding
Transfer-Encoding: chunked
Date: Sun, 24 Jan 2010 18:52:55 GMT
Server: LiteSpeed
Connection: Keep-Alive
Keep-Alive: timeout=5, max=100
Content-Type: text/html; charset=utf-8
Set-Cookie: _redmine_session=207da0c00f02c63e222a19f1b24b4569; path=/
ETag: "699c39b272fae967cd13c71726b8aee8"
X-Runtime: 0.02846
Cache-Control: private, max-age=0, must-revalidate
There is a bit of gibberish above and below. Can't paste it into here though
Last edited: