[Resolved] Yet another problem with Litespeed.

Discussion in 'Bug Reports' started by VortMax, Jun 25, 2010.

  1. VortMax

    VortMax Well-Known Member

    Latest version of IPB Forum software 3.1.1.

    When saving template bits that are being edited in a php text box the software hangs on saving. Switch over to Apache and it works perfectly.

    If I try to click out of the saving routine I get this error:

    Exception: TypeError: t.responseJSON is null

    Anyone have a fix for this?

    1) OS type and Version. If using 64bit OS, please note as such.

    CentOS 5.1 64bit

    2) LiteSpeed Version (Version Number + Model: Standard/Enterprise)

    Any recent version Enterprise

    3) If PHP related: PHP version and interface of choice: FCGI, CGI, or LSAPI.

    LSAPI I believe.
    Last edited by a moderator: Jun 28, 2010
  2. VortMax

    VortMax Well-Known Member

    Here is the config for Litespeed php build:

    and Apache

  3. VortMax

    VortMax Well-Known Member

    Both are showing that php 5.2.9 is running. the above is the build configuration on both and I don't see any significant differences.
  4. VortMax

    VortMax Well-Known Member

    I have about 50 million of these in the error.log file:

    And a number of these:

  5. VortMax

    VortMax Well-Known Member

    It also appears that while it is trying to save that I cannot get into the LSWS control panel or use any of it's menu choices. It just hangs as well.
  6. mistwang

    mistwang LiteSpeed Staff

    check the server from ssh when LSWS web console are affected. It should not be.
    Is PHP running as the same mode for Apache and LiteSpeed? PHP suEXEC or PHP running as the same user that httpd run as. they should match.

    check if "Register_long_array" affect any thing. Compare phpinfo() output line by line.
  7. VortMax

    VortMax Well-Known Member

    apache and litespeed use the same configurations for php and run under the same conditions I believe.

    Are there any specific lines I should be looking at from php info? The output from both is similar in the layout but not exact. It seems that apache and LS are displaying loaded modules in different orders.
  8. VortMax

    VortMax Well-Known Member

    Register Long Arrays are both OFF on apache and litespeed.
  9. VortMax

    VortMax Well-Known Member

    php core from apache and litespeed are exactly the same:

    allow_call_time_pass_reference	Off	Off
    allow_url_fopen	Off	Off
    allow_url_include	Off	Off
    always_populate_raw_post_data	Off	Off
    arg_separator.input	&	&
    arg_separator.output	&	&
    asp_tags	Off	Off
    auto_append_file	no value	no value
    auto_globals_jit	On	On
    auto_prepend_file	no value	no value
    browscap	no value	no value
    default_charset	no value	no value
    default_mimetype	text/html	text/html
    define_syslog_variables	Off	Off
    disable_classes	no value	no value
    disable_functions	, dl , escapeshellcmd , passthru , pfsockopen , posix_kill , posix_mkfifo , posix_setuid , proc_close , proc_open , proc_terminate , system , leak , posix_setpgid , posix_setsid , proc_get_status , proc_nice , show_source	, dl , escapeshellcmd , passthru , pfsockopen , posix_kill , posix_mkfifo , posix_setuid , proc_close , proc_open , proc_terminate , system , leak , posix_setpgid , posix_setsid , proc_get_status , proc_nice , show_source
    display_errors	Off	Off
    display_startup_errors	Off	Off
    doc_root	no value	no value
    docref_ext	no value	no value
    docref_root	no value	no value
    enable_dl	On	On
    error_append_string	no value	no value
    error_log	no value	no value
    error_prepend_string	no value	no value
    error_reporting	6143	6143
    expose_php	Off	Off
    extension_dir	/usr/lib64/php/modules	/usr/lib64/php/modules
    file_uploads	On	On
    highlight.bg	#FFFFFF	#FFFFFF
    highlight.comment	#FF8000	#FF8000
    highlight.default	#0000BB	#0000BB
    highlight.html	#000000	#000000
    highlight.keyword	#007700	#007700
    highlight.string	#DD0000	#DD0000
    html_errors	On	On
    ignore_repeated_errors	Off	Off
    ignore_repeated_source	Off	Off
    ignore_user_abort	Off	Off
    implicit_flush	Off	Off
    include_path	.:	.:
    log_errors	On	On
    log_errors_max_len	1024	1024
    magic_quotes_gpc	Off	Off
    magic_quotes_runtime	Off	Off
    magic_quotes_sybase	Off	Off
    mail.force_extra_parameters	no value	no value
    max_execution_time	30	30
    max_input_nesting_level	64	64
    max_input_time	60	60
    memory_limit	256M	256M
    open_basedir	/var/www/vhosts/easternuswx.com/httpdocs:/tmp	no value
    output_buffering	4096	4096
    output_handler	no value	no value
    post_max_size	8M	8M
    precision	14	14
    realpath_cache_size	16K	16K
    realpath_cache_ttl	120	120
    register_argc_argv	Off	Off
    register_globals	Off	Off
    register_long_arrays	Off	Off
    report_memleaks	On	On
    report_zend_debug	On	On
    safe_mode	Off	Off
    safe_mode_exec_dir	no value	no value
    safe_mode_gid	Off	Off
    safe_mode_include_dir	no value	no value
    sendmail_from	no value	no value
    sendmail_path	/usr/sbin/sendmail -t -i	/usr/sbin/sendmail -t -i
    serialize_precision	100	100
    short_open_tag	On	On
    SMTP	localhost	localhost
    smtp_port	25	25
    sql.safe_mode	Off	Off
    track_errors	Off	Off
    unserialize_callback_func	no value	no value
    upload_max_filesize	10M	10M
    upload_tmp_dir	no value	no value
    user_dir	no value	no value
    variables_order	EGPCS	EGPCS
    xmlrpc_error_number	0	0
    xmlrpc_errors	Off	Off
    y2k_compliance	On	On
    zend.ze1_compatibility_mode	Off	Off
  10. VortMax

    VortMax Well-Known Member

    I tried to make an edit about 15 minutes ago. It finally timed out with these two errors in two pop up boxes:

  11. NiteWave

    NiteWave Administrator

    please try:

    1.edit lsws/conf/mime.properties, add
    json = application/json

    then restart lsws

    if not working yet, try
    2.recomplie LSPHP, just remove
  12. VortMax

    VortMax Well-Known Member

    No luck with:
    json = application/json

    Same result.

    Before I rebuild php with json. json IS also disabled on the apache phpinfo output. Should this really matter?
  13. NiteWave

    NiteWave Administrator

    probably. since mime application/json is seen in apache but not in lsws at the moment.
  14. mistwang

    mistwang LiteSpeed Staff

    Are LiteSpeed PHP and Apache PHP uses the same version of PCRE?
    I think PHP crashed for some reason, and causes 503 errors. Check from ssh if you got PHP process running at 99% cpu when you update.

    You need to strace or GDB attach to the PHP process using 99% CPU to find out what happened.
  15. VortMax

    VortMax Well-Known Member

    Kinda like this?

    I have no idea how to strace or GDB to the PHP processes.

    Are LiteSpeed PHP and Apache PHP uses the same version of PCRE?

    How can I tell this?
  16. mistwang

    mistwang LiteSpeed Staff

    phpinfo shows PCRE version.
    If you use eAccelerator with LiteSpeed PHP, try turning it off see if it helps or not.
  17. VortMax

    VortMax Well-Known Member

    PCRE is the same on both webservers. Is there an option in LSWS to turn off eaccelerator?
  18. NiteWave

    NiteWave Administrator

    in php.ini,comment off
  19. VortMax

    VortMax Well-Known Member

    That does not exist in my php.ini file /etc/php.ini Though I know we are using it because it's installed and the cache files are created on disc.

  20. NiteWave

    NiteWave Administrator

    please grep eaccelerator.so in /etc/php.d

Share This Page