Ruby 1.9

Discussion in 'Ruby/Rails' started by eduardorochabr, Dec 28, 2009.

  1. I'd like to know if a plan for Ruby 1.9 compatibility is on the agenda.

    Thanks.
     
  2. mistwang

    mistwang LiteSpeed Staff

    I think the Rails team need to address the compatibility with Ruby 1.9 first.
    If you know a Rails version works properly with Ruby 1.9, we can start to test and make ruby-lsapi work properly if it is not.
     
  3. Hi mistwang, Rails 2.3.5 is compatible with Ruby 1.9. Maybe you have to apply some patches around to adapt an existent codebase, but it works well.

    https://changelog.com/posts/rails-2-3-5-released

    Would it require some other change besides working on ruby-lsapi?

    Thank you.
     
    Last edited by a moderator: Apr 21, 2017 at 3:10 PM
  4. Grzegorz Derebecki

    Grzegorz Derebecki Well-Known Member

    I think it is good time to start working with lsapi support ruby 1.9.1
     
  5. mistwang

    mistwang LiteSpeed Staff

  6. Grzegorz Derebecki

    Grzegorz Derebecki Well-Known Member

    mistwang thanks i will test it :)
     
  7. mistwang

    mistwang LiteSpeed Staff

    come up with a new fix for empty ENV problem. updated the 4.0 release package.
    Please test it with ruby 1.8.x as well, it should work with both.
     

Share This Page