SNMP Agent...

Discussion in 'Install/Configuration' started by hugemikeyd, Jul 27, 2006.

  1. hugemikeyd

    hugemikeyd Active Member

    I keep getting the error message below when i try and snmpwalk:

    SNMPv2-SMI::enterprises.8888.101 = No Such Instance currently exists at this OID

    When i use V1 i get no message at all. I know my config is ok b/c i can access anything else:

    snmpwalk -c hhpv2 -v 2c localhost .

    Returns a whole bunch of info. All i added to my config was the line:

    pass . /etc/snmp/litespeed/sample.php

    and i replaced the first 2 lines of sample.php to the following:


    Since my php does not use short tags, am i missing something here? Is there a way for me to test it via the command line and no SNMP?
  2. xing

    xing LiteSpeed Staff


    /usr/bin/php /etc/snmp/litespeed/sample.php
    LiteSpeed Web Server
    Excecute the sample.php with no args should give you the litespeed product name and let you know the script is working. Note you need PHP 5.

    Another problem would be your snmpd.conf

    Use only the following 2 lines for your snmpd.conf and restart snmpd.

    rocommunity  public
    pass . /usr/bin/php /etc/snmp/litespeed/sample.php
    If above snmpd.conf works then there is some conflict or misconfig in existing snmpd.conf.
  3. hugemikeyd

    hugemikeyd Active Member

    I tried just running the script and i get no output, are there settings in php.ini that need to be changed?

    PHP 5.1.2 (cli) (built: Feb 28 2006 12:12:16)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

    /usr/local/bin/php sample.php

    Produces no output for me :(
  4. hugemikeyd

    hugemikeyd Active Member

    Am i the only one using this feature? Well trying anyway...
  5. ts77

    ts77 Well-Known Member

    I'm using it and without problems ;).
    running the script manually gives no output for me too, that can't be the cause of your error.
  6. hugemikeyd

    hugemikeyd Active Member

    I am starting to think that there is an issue with my php.ini, i am just really sure where to start...

    Am i supposed to disable safemode?
  7. xing

    xing LiteSpeed Staff

    The php that executes the litespeed snmp bridge sample script, i.e. sample.php, must have read access to the /tmp/lshttpd/ folder. Perhaps safemode is responsible for your problems, but then again maybe now.

    I made an error saying that executing the sample.php script without input parameters would output a value. I was using a customize version.

    For the default sample.php, execute this command:

    php sample.php '-g' .
    and you should get the following output:

    LiteSpeed Web Server
    if you don't get the above output, there is someting wrong with your php and/or php.ini.
    Last edited: Jul 31, 2006
  8. hugemikeyd

    hugemikeyd Active Member

    Warning: file_get_contents(): SAFE MODE Restriction in effect. The script whose uid is 0 is not allowed to access /tmp/lshttpd/.rtreport owned by uid 99 in /etc/snmp/litespeed/class.litespeed_stats.php on line 87

    Warning: file_get_contents(/tmp/lshttpd/.rtreport): failed to open stream: Success in /etc/snmp/litespeed/class.litespeed_stats.php on line 87

    Looks like safe mode is the issue...

    I'll change it in a bit and get back to you
  9. hugemikeyd

    hugemikeyd Active Member

    php -d safe_mode=Off sample.php '-g' .

    LiteSpeed Web Server

    :) Looks like you should mention that safe mode must be turned Off or that the .rtreport file should be owned by the same user executing the script.

Share This Page