[Solved] Admin Web Console Not Loading After New Installation

Discussion in 'Install/Configuration' started by sagesmart, Jun 28, 2011.

  1. sagesmart

    sagesmart New Member

    Using the WHM plugin, I recently installed LSWS using a VPS Enterprise license. Everything appeared to have installed correctly. So, then I clicked on "Build Matching PHP Binary". Again, no apparent errors. I then clicked on "Restart LiteSpeed".

    I then clicked on "Admin Web Console" and Firefox would not load the page. Firefox gave the following message, "The connection has timed out".

    I then uninstalled LSWS and re-installed it to see if that would help, but it did not help.

    Some options I used are as follows:

    LiteSpeed Port Offset is 2000
    I enabled PHP suEXEC

    The only thing that looked suspicious during the LSWS installation was this message:

    Generating key pair for web console login page, please wait ...
    Generating RSA private key, 512 bit long modulus
    unable to write 'random state'

    I have no clue what that message is about and I don't know if that has anything to do with why I can't load the Admin Web Console (or any other web page on my site) using LiteSpeed on port 2080 (which I thought I would be able to with a port offset of 2000).

    Any ideas on what might be going on here?
  2. cmanns

    cmanns Well-Known Member

    are you running CSF firewall? If so try opening the port....:rolleyes:

  3. webizen

    webizen Well-Known Member

    Admin Console is listening on port 7080 by default.
  4. sagesmart

    sagesmart New Member

    Thanks for the tips.

    Port 7080 was indeed being blocked by my firewall. So, I opened up port 7080. However, I'm still not able to view the web console when I click on it.

    Any ideas on where to go from here?
  5. webizen

    webizen Well-Known Member

    check if port 7080 is listening. For CentOS, try below from command line:

    if no result, try start LSWS from command line:
  6. Jeffwar

    Jeffwar Member

    Having same problem. When I do the netstat, it says

    tcp 0 0* LISTEN 8893/litespeed (lsh

    Any ideas or help? Thanks!
  7. webizen

    webizen Well-Known Member

    It is likely your firewall blocks TCP port 7080 access from outside.
  8. Jeffwar

    Jeffwar Member

    I don't have a firewall setup? Not one that I know of atleast. I am running a liquid web 1 gig VPS.
  9. webizen

    webizen Well-Known Member

    do from command line and see if you get anything back
  10. Jeffwar

    Jeffwar Member

    First one yielded: ** are of course substitute

    Trying 50.28.**.***...
    Connected to 50.28.**.***.
    Escape character is '^]'.


    HTTP/1.1 302 Found
    Date: Thu, 07 Jul 2011 03:39:20 GMT
    Server: LiteSpeed
    Connection: Keep-Alive
    Keep-Alive: timeout=5, max=100
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: LSWSWEBUI=2eb2187cedda2aaf9d07c87491bc1944; path=/
    Set-Cookie: lsws_uid=a; expires=Tue, 07 Jun 2011 03:39:20 GMT; path=/
    Set-Cookie: lsws_pass=b; expires=Tue, 07 Jun 2011 03:39:20 GMT; path=/
    Set-Cookie: LSWSWEBUI=b; expires=Tue, 07 Jun 2011 03:39:20 GMT; path=/
    location: /login.php
    Content-Type: text/html
  11. webizen

    webizen Well-Known Member

    The LSWS service is up and running. There must be firewall somewhere between you and the server blocking you from accessing LSWS.

  12. Jeffwar

    Jeffwar Member

    Yes, problem fixed. There was an additional firewall, and I added port 7080. Works fine now.


Share This Page