[Solved] Call to undefined function mysql_connect() error

Discussion in 'PHP' started by dougconran, Mar 13, 2011.

  1. dougconran

    dougconran Member

    I need to be able to run Wordpress and, for that, I need PHP.

    I've compiled PHP using the 'Compile PHP' option under 'Actions' and then manually built PHP (with --with-mysqli).

    I then ran 'sudo -u nobody ./lsphp5 -i' and have confirmed that mysqli is present.

    I've run phpinfo in a web browser which shows a whole lot of info about Mysql and which indicates that PHP itself is working.

    However, when I try and connect to an existing Mysql database I get the following error message:-

    Fatal error: Call to undefined function mysql_connect() in /usr/local/httpd/htdocs/phptest.php on line 10

    How can I resolve this as I need PHP with Mysql for Wordpress?



    PS - I'm on SuSE Linux 11.3 and Litespeed v4.0.18
  2. webizen

    webizen Well-Known Member

    you need '--with-mysql' option
  3. dougconran

    dougconran Member

    Thank you for a very quick reply.

    The build file already had '--with-mysqli' as a configure parameter. I did try adding '--with-mysql' immediately before '--with-mysqli' to the initial configure statement however, on re-building, it appeared to ignore mysql in favour of mysqli.

    Should I REPLACE '--with-mysqli' with '--with-mysql' or do I need to do something different?


  4. webizen

    webizen Well-Known Member

    you can try '--with-mysql=/usr --with-mysqli' or '--with-mysql=/usr' (without mysqli). Essentially option '--with-mysql' is needed for mysql_* functions (e.g. mysql_connect()). You may use mysqli_* function in your php script if --with-mysql does not work for you.
  5. dougconran

    dougconran Member

    Solved - Call to undefined function mysql_connect() error

    Problem solved!

    In fact your first answer fixed the problem but when I first tried it I had managed to add the --with-mysql to the comment rather than the configure statement :mad: (It was late at night).

    Anyway all is working perfectly now - again, many thanks for such good and swift help.



Share This Page