[Solved] Can't get the server to run

Discussion in 'General' started by 88guy, Nov 1, 2012.

  1. 88guy

    88guy New Member

    This is crazy - I installed this once, and it ran fine. I tried to upgrade PHP and, when it failed (it said it couldn't find wget, fetch, or curl) I uninstalled with the intention of performing the installation again. That was 3 days ago. I have never been able to get it running, again. I've now downloaded multiple copies of the standard version and run this installation about 20 times. I was using Centos but I eventually tried it on Ubuntu, just to see if it made any difference. I'm accepting the default path, choosing not to install AWstats, and at the end of the install I see this:
    Would you like to have LiteSpeed Web Server started automatically
    when the server restarts [Y/n]? Y
    [OK] The startup script has been successfully installed!
    Would you like to start it right now [Y/n]? Y
    [OK] litespeed: pid=19989.
    LiteSpeed Web Server started successfully! Have fun!
    But, when I go to "localhost" - or use the IP number (I'm setting it to port 80) - there's nothing! It just says this page cannot be displayed. The error log looks like this:
    2012-11-01 12:30:02.289 [NOTICE] Loading LiteSpeed/4.2 Standard ...
    2012-11-01 12:30:02.291 [NOTICE] [ADMIN] server socket: uds://usr/local/lsws/admin/tmp/admin.sock.7923
    2012-11-01 12:30:02.291 [NOTICE] Loading configuration from /usr/local/lsws/conf/httpd_config.xml ...
    2012-11-01 12:30:02.292 [INFO] old priority: 0, new priority: 0
    2012-11-01 12:30:02.292 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2012-11-01 12:30:02.295 [NOTICE] [PID: 19989]: start cgid: 19993, /usr/local/lsws/bin/httpd
    2012-11-01 12:30:02.295 [NOTICE] The maximum number of file descriptor limit is set to 4096.
    2012-11-01 12:30:02.296 [WARN] [config:server:rails] Cannot find ruby interpreter, Rails easy configuration is turned off
    2012-11-01 12:30:02.298 [NOTICE] litespeed (19989) is ready
    2012-11-01 12:30:02.298 [NOTICE] [Child: 19994] Setup swapping space...
    2012-11-01 12:30:02.298 [NOTICE] [child: 19994] Successfully change current user to nobody
    2012-11-01 12:30:02.298 [NOTICE] [Child: 19994] Core dump is enabled.
    2012-11-01 12:30:02.298 [NOTICE] [Child: 19994] LiteSpeed/4.2 Standard starts successfully!
    2012-11-01 12:30:02.298 [NOTICE] [AutoRestarter] new child process with pid=19994 is forked!
    2012-11-01 12:30:03.103 [NOTICE] [AutoUpdate] Checking for new releases..., pid=19996
    2012-11-01 12:30:03.116 [NOTICE] Start to clean up cache directory, pid=19997
    2012-11-01 12:30:03.388 [INFO] Stop listener *:80.
    2012-11-01 12:30:03.388 [INFO] Stop listener *:7080.
    2012-11-01 12:30:03.388 [NOTICE] [Child: 19994] Start shutting down gracefully ...
    2012-11-01 12:30:03.388 [NOTICE] New litespeed process is ready, stop listeners
    2012-11-01 12:30:03.388 [INFO] Stop listener *:80.
    2012-11-01 12:30:03.388 [INFO] Stop listener *:7080.
    2012-11-01 12:30:03.388 [NOTICE] [Child: 19994] Shut down successfully! 
    2012-11-01 12:30:03.389 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets of process with pid=19994 !
    2012-11-01 12:30:03.490 [NOTICE] [AutoRestarter] child process with pid=19994 exited with status=0!
    2012-11-01 12:30:03.490 [NOTICE] [PID:19989] Server Stopped!
    This is the standard, free version. Do I need a key or something. Why is this simply stopping?
    Last edited: Nov 1, 2012
  2. NiteWave

    NiteWave Administrator

    you can PM me the server's root access. I can take a quick look.
  3. webizen

    webizen Well-Known Member

    The ip is clear now.
  4. 88guy

    88guy New Member


    I had a server issue - with Apache - and was tied up for a couple of days. I finally got back to this.....works fine, now. Thanks a lot.

Share This Page