[solved] Failed to initialize VMemBuf!

Discussion in 'General' started by Mr_Parham, Aug 13, 2012.

  1. Mr_Parham

    Mr_Parham Well-Known Member


    I recently installed a new script on my server, it's a link generator so it use my server as a proxy i would say to get the link from another server and allow the user to download it. now the problem is the number of the users are using it is increasing and the system stoped working! here is the error i get in litespeed admin area


    and here is what the user would see when they try to download the files


    I also tried increasing the memory soft/hard limit in External Application Resource but it seems like it didnt help at all :(
    Last edited by a moderator: Aug 17, 2012
  2. NiteWave

    NiteWave Administrator

    php in suExec mode or not ?
    how frequently did it happen? (you can search error log for "Failed to initialize VMemBuf")
    and please post your lsphp5 settings here
  3. Mr_Parham

    Mr_Parham Well-Known Member

    I think it is =/ but i'm not sure how can i check
    i tried searching it and it suggested increasing the memory limit which didnt help me at least
    it started about 10 hours ago (base on what customers are telling me) and it's not stopping for now
    all of the settings :l ??
  4. Mr_Parham

    Mr_Parham Well-Known Member

  5. Mr_Parham

    Mr_Parham Well-Known Member

    I got about 1000 emails by now saying

    LiteSpeed Web server srv1.expressvds.com on srv1.expressvds.com restarts automatically to fix 503 Errors
  6. mistwang

    mistwang LiteSpeed Staff

  7. Mr_Parham

    Mr_Parham Well-Known Member

  8. webizen

    webizen Well-Known Member

  9. Mr_Parham

    Mr_Parham Well-Known Member

  10. mistwang

    mistwang LiteSpeed Staff

  11. Mr_Parham

    Mr_Parham Well-Known Member

    As soon as i done that i'm getting hundreds of such an email
    At [14/Aug/2012:08:49:17 -0400], web server with pid=26270 received unexpected signal=6, a core file is created. A new instance of web server will be started automatically!

    Please forward the following debug information to bug@litespeedtech.com.

    Server: LiteSpeed/4.1.13 Enterprise
    OS: Linux
    Release: 2.6.32-279.1.1.el6.x86_64
    Version: #1 SMP Tue Jul 10 13:47:21 UTC 2012
    Machine: x86_64

    If the call stack information does not show up here, please compress and forward the core file located in /tmp/lshttpd/.

    [New Thread 26270]
    [New Thread 26274]
    [New Thread 26273]
    Core was generated by `litespeed'.
    Program terminated with signal 6, Aborted.
    #0 0x00007fb3423878a5 in ?? ()
    #0 0x00007fb3423878a5 in ?? ()
    #1 0x00007fb342389085 in ?? ()
    #2 0x0000000000000005 in ?? ()
    #3 0x0000000001b4b0c0 in ?? ()
    #4 0x0000000000633f32 in ?? ()
    #5 0x00000000004459c7 in ?? ()
    #6 0x00000000019f7b50 in ?? ()
    #7 0x0000000001b4b0c0 in ?? ()
    #8 0x00007fb34235bb58 in ?? ()
    #9 0x00007fb3426e7000 in ?? ()
    #10 0x00007fff00000005 in ?? ()
    #11 0x0000000000679694 in ?? ()
    #12 0x0000000000000000 in ?? ()

    and also when i log in in to the litespeed admin area it says

    2012-08-14 08:49:36.113 WARN [AutoRestarter] forking too frequently, suspend for a while!
  12. NiteWave

    NiteWave Administrator

    this issue has been resolved:
  13. bobykus

    bobykus Well-Known Member

    fixed it by cleaning swap
    Last edited: Oct 19, 2012

Share This Page