[Solved] images problem

Discussion in 'General' started by hamdiboy, Jan 31, 2013.

  1. hamdiboy

    hamdiboy Member

    It was working very fine with apache.

    I just install litespeed via directadmin plugin.

    Now i cant see images on my wordpress website

    I recomplicate php with previous apache config.

    [root@server ~]# ldd /usr/local/lsws/fcgi-bin/lsphp5
    linux-vdso.so.1 => (0x00007fffd17fd000)
    libcrypt.so.1 => /lib64/libcrypt.so.1 (0x0000003758800000)
    librt.so.1 => /lib64/librt.so.1 (0x0000003758000000)
    libpng12.so.0 => /usr/local/lib/libpng12.so.0 (0x00002ab023092000)
    libz.so.1 => /usr/local/lib/libz.so.1 (0x00002ab0232b5000)
    libm.so.6 => /lib64/libm.so.6 (0x0000003757800000)
    libresolv.so.2 => /lib64/libresolv.so.2 (0x0000003759000000)
    libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003758c00000)
    libmysqlclient.so.16 => /usr/lib64/libmysqlclient.so.16 (0x00002ab0234cc000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003757400000)
    libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x00002ab0237d3000)
    libdl.so.2 => /lib64/libdl.so.2 (0x0000003757000000)
    libiconv.so.2 => /usr/local/lib/libiconv.so.2 (0x00002ab023b16000)
    libc.so.6 => /lib64/libc.so.6 (0x0000003756c00000)
    /lib64/ld-linux-x86-64.so.2 (0x0000003756800000)

    what should i do?
  2. hamdiboy

    hamdiboy Member

    [STDERR] require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/ece/index.php'), the_excerpt_rss,$
    2013-01-31 16:34:45.552 [NOTICE] []
    [STDERR] require('wp-blog-header.php'), require_once('wp-includes/template-loader.php')
    , include('/themes/ece/index.php'), the_excerpt_rss, get_the_excerpt,
    apply_filters('get_the_excerpt'), call_user_func_array, wp_trim_excerpt,
    apply_filters('the_content'), call_user_func_array, automaticSeoLinksChange,
    W3_Db->query taraf..ndan olu..turulan select * from wp_automaticSEOlinks
    where idGroup=0 sorgusu i..in WordPress veritaban.. hatas.. Table 'eceerken_huzurg1.wp_automaticSEOlinks' doesn't exist
  3. webizen

    webizen Well-Known Member

    this is more of file permission issue. nothing to do with wp table missing.
  4. hamdiboy

    hamdiboy Member

    i pmed my website link to you.

    i already enabled suexec and it was working with apache as i told..

    what should i do to fix ?
  5. webizen

    webizen Well-Known Member

    are you running cpanel? or other control panel?

    check the owership and permission of the file. make sure webserver user (nobody) has read permission to the file.
  6. hamdiboy

    hamdiboy Member

    i use directadmin

    how can i check

    "make sure webserver user (nobody) has read permission to the file."
  7. hamdiboy

    hamdiboy Member

  8. hamdiboy

    hamdiboy Member

    i see that all images owner is apache

    is it normal ?
  9. webizen

    webizen Well-Known Member

    If this is shared hosting, then they *should* be owned by vhost owner. The 403 error is likely due to image ownership mismatch with the vhost ownership and you have Force Strict Ownership (Admin Console => Server => Security) set to Yes. You can either set to No or correct the ownership on the image files.
  10. hamdiboy

    hamdiboy Member

    it worked .. thanks

Share This Page