[solved] LiteSpeed And Wordpress

Discussion in 'Install/Configuration' started by John Doe, Mar 19, 2011.

  1. John Doe

    John Doe Active Member


    i use to run the dinosaur called Apache on my server but it could not handle the load on my website so I installed lite speed which is working wonders for my website but the only problem I have is with litespeed and wordpress.

    When I had Apache I use to have suExec And SuPHP and I was able to upgrade wordpress without having to enter my FTP info like shown in this example below:


    I also notice when it comes to configuring plugins with wordpress I have to manually go and change the chmod on folders and files to 777 just to change the settings and sometimes i forget to change it back and I know that dangerous but when I had Apache I never had this problem.

    What can I do to fix this issue?
    Last edited by a moderator: Mar 21, 2011
  2. NiteWave

    NiteWave Administrator

    it's permission issue.

    check which user lsphp5 is running as, assume nobody.
    (ps -ef|grep lsphp5)


    chown -R nobody:nobody wordpress-root-directory

    will fix those issues.
  3. John Doe

    John Doe Active Member

    That has done the trick...

    May God Bless You Kind Sir:D

    Quick Question, when I try to chmod a file via FTP now it tells me Permission denied im assuming its because im no longer considered as a privileged user since the rights were changed to the user nobody, is there anyway around this?
    Last edited: Mar 19, 2011
  4. NiteWave

    NiteWave Administrator

    an example, FYI only:
    chown -R user1:nobody root-of-wordpress
    chmod -R 770 root-of-wordpress
  5. John Doe

    John Doe Active Member

    Thank You very much.
  6. John Doe

    John Doe Active Member


    I know this thread is old but I am still seem to be having trouble.. The reason I did not reply back sooner was because I had switched back to apache but now im using litespeed again.

    I followed you suggestions as quoted but all this did was allow me to use the FTP again but now im back to the same problem with wordpress asking for credentials again... Any suggestions?
    Last edited by a moderator: Aug 23, 2011
  7. NiteWave

    NiteWave Administrator

    refer #2 reply:
    check which user lsphp5 is running ?
  8. John Doe

    John Doe Active Member

    Ok here is the output from SSH:

    root@blacksteal [~]# ps -ef|grep lsphp5
    nobody 22378 22333 0 07:03 ? 00:00:00 lsphp5
    nobody 32067 22378 12 07:21 ? 00:00:13 lsphp5
    nobody 32300 22378 15 07:22 ? 00:00:05 lsphp5
    nobody 32391 22378 14 07:22 ? 00:00:01 lsphp5
    root 32410 1780 0 07:22 pts/0 00:00:00 grep lsphp5
  9. NiteWave

    NiteWave Administrator

    odd. it should work. then how about:
    chown -R nobody:nobody wordpress-root-directory

    you can change back when you've done upgrade:
    chown -R user1 wordpress-root-directory
  10. John Doe

    John Doe Active Member

    That seems to work but the problem is I have over 175 sites and every few days/weeks the are new plugin upgrades. wordpress upgrades, etc... That would literary take me a few hours to loin to each account and SSH just to perform upgrades...

    When I had apache I use my automated script to do all of this because I was running ever account under its user name so there was never any permission errors...

    Do you guys have some sort of function or plugin were lite speed can emulate this?
  11. NiteWave

    NiteWave Administrator

    so are you providing wordpress hosting? I thought it's a standalone wp setup.

    then enable php suExec

    lsws admin console:)7080)==>
    Configuration=>Server=>General=>PHP suEXEC:Yes

    lsphp5 will run as each account's user. ALL WP upgrade should be ok.
  12. John Doe

    John Doe Active Member

    Im not hosting other peoples blogs, are of them are mine.

    As soon as I enable suEXEC all my sites become painfully slow... do you know what the issue could be as to why it slows down with suEXEC enabled?
  13. NiteWave

    NiteWave Administrator

    with php suExec, APC or xcache almost useless, so slow down.

    since all of the blogs are yours .... are these blogs under same user account or different user accounts?
  14. John Doe

    John Doe Active Member

    They are all under different accounts.

    and yes im using xcache so that's why it became so slow? Do I have to disable it?
  15. NiteWave

    NiteWave Administrator

    no. you don't have to disable it, but it's no much help for performance.
  16. John Doe

    John Doe Active Member

    Ok thanks, I installed eaccelerator and now all problems are solved..
  17. NiteWave

    NiteWave Administrator

    thanks. so php suExec + eAccelerator is still a good combination in shared hosting environment.
  18. John Doe

    John Doe Active Member

    Yep, to be honest it seems like the only combination since any other caching system will turn the server into molasses..

    I am using php eAccelerator 9.5.3 since that's the last one that support's user object cache and I notice my server became twice as fast as before even with suExec enabled

Share This Page