[Solved] Litespeed + Cpanel: awstats not working after installation

Discussion in 'General' started by fernandomm, Feb 25, 2011.

  1. fernandomm

    fernandomm Active Member


    After i have installed Litespeed on a Cpanel box awstats stopped working for all users.

    I've doubled checked the configuration in Cpanel and Awstats is enabled.

    How can i check what's causing this issue? Is any configuration required in Litespeed?

  2. webizen

    webizen Well-Known Member

    Is awstats not accessible or stats no longer changing?
  3. fernandomm

    fernandomm Active Member

    Stats are no longer changing.
  4. webizen

    webizen Well-Known Member

    check domlogs (e.g. /usr/local/apache/domlogs/domain). if they are not growing, do one of the followings:
    1. Do force-reinstall lsws from WHM Plugins -> LiteSpeed Web Server -> Admin Web Console (Actions -> Version Manager )
    2. Download lsws package and re-install from command line. Use 'U'pgrade option to keep your existing configurations.
  5. fernandomm

    fernandomm Active Member

    All logs inside /usr/local/apache/domlogs/ are indeed empty.

    I tried the reinstall option but unfortunately it didn't worked, they are still not being updated.

    Anything else that i can try?
  6. webizen

    webizen Well-Known Member

    If you have tried both options and it is still not working, pm your server temporary root access if you would like us to further investigate it.
  7. webizen

    webizen Well-Known Member

    Received your server access info earlier today and just checked your server.

    CustomLog for each account is missing in apache conf file (/usr/local/apache/conf/httpd.conf). In other words, logging was turned off by your admin via cPanel. That's why no access log is generated in domlogs folder and awstats is not showing anything.
    Last edited: Mar 3, 2011
  8. webizen

    webizen Well-Known Member

    Apache logging (CustomLog/domlogs) being turned off is because Apache piped logging was enabled in cPanel. To disable it, go to WHM -> Service Configuration -> Apache Configuration -> Piped Log Configuration -> uncheck "Enable piped Apache logs" (it is checked currently) -> Save.
    Last edited: Mar 4, 2011

Share This Page