[solved] litespeed weird behavior

Discussion in 'General' started by litespeederr, Jan 4, 2013.

  1. litespeederr

    litespeederr New Member

    Hi, i use litespeed 4.1.7 and for 1 domains is having a weird bihavior.
    When i use litespeed, 1 domain is redirecting to other domain without any rules set in cpanel, ftp or dns.
    When i switch to apache the domains is working normaly.

    Where should I look for any more information to solve the problem with litespeed and this weird redirect ?
    Last edited by a moderator: Jan 11, 2013
  2. mistwang

    mistwang LiteSpeed Staff

    You should upgrade to 4.1.13 or 4.2.1

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.1.13


    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.1
  3. litespeederr

    litespeederr New Member

    not working,

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.1
    2013-01-04 21:10:47.353 [NOTICE] [AutoUpdate] Checking for new releases..., pid=442381
    expr: syntax error
    /usr/bin/wget -nv -O /usr/local/lsws/autoupdate/lsws-4.2.1--x86_64-linux.tar.gz http://www.litespeedtech.com/packages/4.0/lsws-4.2.1--x86_64-linux.tar.gz
    2013-01-04 21:10:49 ERROR 404: Not Found.
    /usr/local/lsws/admin/misc/update.sh 4.2.1  x86_64-linux
      Upgrade to another version of LiteSpeed web server. the package file must
      exist under /usr/local/lsws/autoupdate/
      Package file should be lsws-VERSION-EDITION-PLATFORM.tar.gz
    Restarting LSWS
    [OK] Send SIGUSR1 to 441196
    root@server4 [~]# wget
    wget: missing URL
    Usage: wget [OPTION]... [URL]...
    Try `wget --help' for more options.
  4. NiteWave

    NiteWave Administrator

    what's current value of following files?

    please try delete all files under /usr/local/lsws/autoupdate/
    and run
    /usr/local/lsws/admin/misc/lsup.sh ...
  5. litespeederr

    litespeederr New Member

    root@server4 [~]# /usr/local/lsws/autoupdate/platform
    -bash: /usr/local/lsws/autoupdate/platform: Permission denied
    root@server4 [~]# /usr/local/lsws/autoupdate/release
    -bash: /usr/local/lsws/autoupdate/release: Permission denied
    root@server4 [~]# cd /usr/local/lsws/autoupdate/
    root@server4 [/usr/local/lsws/autoupdate]# ls
    ./                                   lsws-4.1.13-ent-x86_64-linux.tar.gz
    ../                                  lsws-4.1.13--x86_64-linux.tar.gz
    .last                                lsws-4.2.1--x86_64-linux.tar.gz
    lsws-4.1.12/                         platform
    lsws-4.1.12-ent-x86_64-linux.tar.gz  release
    lsws-4.1.13/                         update.log
    root@server4 [/usr/local/lsws/autoupdate]# ls -als
    total 6472
       4 drwx------  4 lsadm lsadm     4096 Jan  4 21:10 ./
       4 drwxr-xr-x 16 root  root      4096 Nov 16  2011 ../
       0 -rw-r--r--  1 root  nobody       0 Jan  5 14:05 .last
       4 drwxr-xr-x 12  1000 users     4096 May 26  2012 lsws-4.1.12/
    3176 -rw-r--r--  1 lsadm lsadm  3247441 May 26  2012 lsws-4.1.12-ent-x86_64-linu                                                                                                                                                             x.tar.gz
       4 drwxr-xr-x 12  1000 users     4096 Nov  7 00:14 lsws-4.1.13/
    2864 -rw-r--r--  1 lsadm lsadm  2924694 Nov  7 00:14 lsws-4.1.13-ent-x86_64-linu                                                                                                                                                             x.tar.gz
       0 -rw-r--r--  1 root  root         0 Nov  6 23:15 lsws-4.1.13--x86_64-linux.t                                                                                                                                                             ar.gz
       0 -rw-r--r--  1 root  root         0 Jan  4 21:10 lsws-4.2.1--x86_64-linux.ta                                                                                                                                                             r.gz
       4 -rw-r--r--  1 lsadm lsadm       12 Jan  5 14:05 platform
       4 -rw-r--r--  1 lsadm lsadm       24 Jan  5 14:05 release
     408 -rw-r--r--  1 lsadm lsadm   413448 Jan  5 14:05 update.log
    root@server4 [/usr/local/lsws/autoupdate]#
    root@server4 [/usr/local/lsws/autoupdate]# rm -rf *
    root@server4 [/usr/local/lsws/autoupdate]# /usr/local/lsws/admin/misc/lsup.sh
    2013-01-05 14:40:51.151 [NOTICE] [AutoUpdate] Checking for new releases..., pid=872714
    /usr/bin/wget -nv -O /usr/local/lsws/autoupdate/lsws-4.2.1-ent-x86_64-linux.tar.gz http://www.litespeedtech.com/packages/4.0/lsws-4.2.1-ent-x86_64-linux.tar.gz
    2013-01-05 14:41:08 URL:http://www.litespeedtech.com/packages/4.0/lsws-4.2.1-ent-x86_64-linux.tar.gz [5723638/5723638] -> "/usr/local/lsws/autoupdate/lsws-4.2.1-ent-x86_64-linux.tar.gz" [1]
    /usr/local/lsws/admin/misc/update.sh 4.2.1 ent x86_64-linux
    2013-01-05 14:41:09.147 [NOTICE] [OK] Updated license key has been created at /usr/local/lsws/autoupdate/lsws-4.2.1/license.key.
    groupadd: group lsadm exists
    useradd: user lsadm exists
    Warning:  --directory (-d) option is undocumented and no-op.
     Use -rf for deleting non-empty dirs
    EasyApache Hooks is enabled, update scripts
    LiteSpeed Web Server Plugin for WHM Installed.
    You can access it from WHM web console plugins section.
    Restarting LSWS
    [OK] Send SIGUSR1 to 856274
    root@server4 [/usr/local/lsws/autoupdate]# /usr/local/lsws/autoupdate/platform
    -bash: /usr/local/lsws/autoupdate/platform: Permission denied
    root@server4 [/usr/local/lsws/autoupdate]# /usr/local/lsws/autoupdate/release
    -bash: /usr/local/lsws/autoupdate/release: Permission denied
    root@server4 [/usr/local/lsws/autoupdate]#
    Litespeed in whm it's shows Current Version: 4.2.1, but the mail problema with the redirect still exists.

    any new idea?
  6. NiteWave

    NiteWave Administrator

    please PM the problem domain name
  7. litespeederr

    litespeederr New Member

    I have solved the problem.
    There was a .htaccess file in the user root directory with redirect instructions.

    I have ignored this file from the start because I assumed the .htaccess file will not have efect if it's not in the public_html directory

Share This Page