[solved] Locale

Discussion in 'Install/Configuration' started by akia, Dec 10, 2012.

  1. akia

    akia Member

    I'm having problems with litespeed and locale settings.

    I'm running invision power board and I've got the calendar widget on the homepage that displays the date.

    The locale setting is set to en_GB in invision, but it dosn't look like litespeed is working with this, as the date formate is still in the american format of MM/DD/YY

    I've spent all day trying to figure it out, even submitting a ticket with cpanel, its definitely something to do with litespeed as if if switch back to Apache, then the date format starts to show properly with the UK format, DD/MM/YY.

    Is there a setting or something within litespeed that I've missed.
    Last edited by a moderator: Jan 10, 2013
  2. NiteWave

    NiteWave Administrator

    I think locale setting should be taken care of the php script (invision power board), or lsphp5.

    any difference of phpinfo() between apache and lsws ?
  3. akia

    akia Member

    Not that I can tell,

    Its really puzzling, I've built a matching Php binary, but as soon as I switch to Apache it works with the UK format no problem, switch back to litespeed and it goes back the to US format.
  4. NiteWave

    NiteWave Administrator

    looks it can be customized.

    in IP.Board's AdminCP
    -> Other Apps
    -> Calendar
    -> Calendar Settings
    -> Time / Date Formatting
    -> Date format:
    there are 4 choices available:
  5. akia

    akia Member

    Well thats what I thought, but its set right in IPB and I've logged a ticket with them and got the following response:

    For the date issue, your language packs are correctly set to en_GB so this means that either the en_GB locale is not correctly installed on your web server or your web host is overriding the locale, possibly via a default PHP setting which is why the British locale / date format is not taking affect. Please pass this on to them and ask them to investigate further.

    Like I said if I switch back to Apache it works fine, its jsut when running litespeed as the server that it becomes a problem.

    I've read that it might be to do with a chroot setting but looking at the litespeed settings the option for chroot are set to no.
  6. akia

    akia Member

    I've tried some more tests, just to rule out IPB.

    I've uploaded a sample php file with the following in:

    strftime(" in Finnish is %A,");
    strftime(" in French %A and");
    strftime(" in German %A.\n");
    With Apache running I get:

    Monday in Finnish is maanantai, in French lundi and in German Montag.

    With litespeed running I get:
    Monday in Finnish is Monday, in French Monday and in German Monday.
  7. NiteWave

    NiteWave Administrator

    good test script. I ran it with lsphp5, both on command line and lsws, the result is
    so no problem at my test. can you run it at command line:
    #/usr/local/lsws/fcgi-bin/lsphp5 /path/to/test.php
  8. akia

    akia Member

    well i'm really puzzled by this,

    I had to leave it and revert back to our old server as I couldn't figure it out, I thought now xmas and the new year is over I'd revisit it, so have quickly set up a test install and the test script seems to be running fine. So not sure what the problem was. I shall look at making the move back over soon and see if I have the same problem.
  9. akia

    akia Member

    Right I think I've tracked down the problem, its got something to do with APC, as soon as I install it and turn on the caching does the problem appear again. Not sure why it dosn't seem to like litespeed though as if I switch back to apache with APC still running do the locales work fine again.
  10. akia

    akia Member

    I've tried using xcache as well, and that has the same problem.

    But not if I run it from the command line.
  11. NiteWave

    NiteWave Administrator

    good point ... then I tried to enable APC, but result is same:
  12. akia

    akia Member

    Well I was puzzled by that, so have done some more digging by the process of elimination.

    I orginally had a shared memory size of 256m, Its seems that you can set apc.shm_size upto 249M and it works fine, as soon as you go over 250 then the locales stop working.

    Really really odd as to why. but at least I know why it wasn't working now, I will just keep my memory size to below 250m, and if i need more I'll have smaller memory sizes but go back to each user having their own memory isntance.
  13. NiteWave

    NiteWave Administrator

    this suggested me a default setting for lsphp5 external app:

    lsws admin console->Server->External App->lsphp5->
    Memory Soft Limit (bytes):250M
    Memory Hard Limit (bytes):300M

    can you increase the soft/hard limit to 300M/350M and see if working for apc.shm_size = 256M ?
  14. akia

    akia Member

    its already set higher than that.

    Attached Files:

  15. NiteWave

    NiteWave Administrator

    then what's the memory_limit value in phpinfo() ?
  16. akia

    akia Member

    It's set to 128mb
  17. webizen

    webizen Well-Known Member

    raise memory limit (soft/hard) in lsphp5 to 512M or higher.
  18. akia

    akia Member

    Yep, that's fixed it. Thanks

Share This Page