[solved] lsphp command using 100+% cpu usage

#1
Hii, I have VPS with litespeed webserver everything is working fine but sometimes lsphp commands are using 100+% cpu usage when I saw with top command. I want to know why it is using cpu resources at high level. I am posting the screenshot of command line here. Please help me and look into the matter.
Load average is 4.27, 4.20, 4.78
ss.png
 

Pong

Well-Known Member
Staff member
#2
100% only means one core. You may have many cores on the server. PHP sometimes could be very heavy depend on your appalication, nothing to do with LiteSpeed Web Server.

You should enable cache for atestkqg domain, which will try to avoid PHP processes.
 

Pong

Well-Known Member
Staff member
#4
maybe I did not clarify enough, High PHP usage is something on the PHP application, not on LiteSpeed, but LScache can help/mitigate such situation.
What application do you use? Is it a wordpress site? What's the URL?
Did you verify the header to ensure cthe ache is working?
 
#5
It is codingniter website develpped in php and I found nothing in php code which can cause the issue even everything was working fine on a previous shared server.
 

NiteWave

Administrator
#9
this will be more helpful to know which file it's reading ... endless reading likely a big problem.
you can "lsof -p pid" to know which files the lsphp has opened.
 
Top