[solved] LSWS not restarting when Plesk restarts Apache

Discussion in 'General' started by javii, Oct 27, 2011.

  1. javii

    javii Member


    I'm testing LSWS to use on a Plesk 10.3 server, everything is working fine but if I left LSWS configured to auto reload changes with Apache binary wrapper, it doesn't work.

    I have configured to "(depricated) yes" and it works, but I would like to setup with Apache binary wrapper.

    Any idea?

    It is a Plesk 10.3 server running on Centos 5.5.

    Best regards.
    Last edited by a moderator: Nov 11, 2011
  2. mistwang

    mistwang LiteSpeed Staff

    Please check

    see if there is anything logged during the restart.
  3. javii

    javii Member

    This is what I have:

    jue oct 27 02:14:11 CEST 2011: -k graceful
    Thu Oct 27 02:14:35 CEST 2011: -t
    jue oct 27 02:14:36 CEST 2011: -t
    jue oct 27 02:14:36 CEST 2011: -k graceful
    Thu Oct 27 02:17:32 CEST 2011: -t
    jue oct 27 02:17:33 CEST 2011: -t
    jue oct 27 02:17:33 CEST 2011: -k graceful
    Thu Oct 27 09:21:22 CEST 2011:
    Thu Oct 27 09:22:06 CEST 2011:
    Thu Oct 27 09:22:40 CEST 2011:
    Thu Oct 27 09:26:59 CEST 2011: -t
    Thu Oct 27 09:28:50 CEST 2011: -t
    Thu Oct 27 09:30:58 CEST 2011: -t
    jue oct 27 10:03:50 CEST 2011: -t
    jue oct 27 10:04:32 CEST 2011: -t
  4. javii

    javii Member

    any idea?

    I also get these emails when Plesk changes something:

    Can not restart web server.

    I suppose Plesk try to start Apache using port 80, but this is not possible because Lsws is using that port.

    I will buy a LSWS enterprise license if I solve these two little problems.
  5. javii

    javii Member

    I think the problem is related with the wrapper.

    In LSWS admin I have this:
    Apache Binary Path /usr/sbin/httpd

    But, this is Apache binary, where is the wrapper?

    thank you.

    best regards
  6. mistwang

    mistwang LiteSpeed Staff

    The Apache binary is replaced with a shell script if wrapper enabled.
    However, plesk does not call the binary directory when restart, so it is recommended not to use binary wrapper for now. We will investigate.
  7. javii

    javii Member

    Ok, so I will leave configured for restarting LSWS when detects any change in the configuration for now.

    Is there any way to avoid Plesk messages telling it is not able to restart webserver? I am getting about 10 emails per day.
  8. mistwang

    mistwang LiteSpeed Staff

    We installed plesk 10 in our lab.
    Seems LSWS with using httpd wrapper is working fine.
    We tried "restart" apache from service management page of plesk, LSWS restarts, we added a new account, LSWS restarts as well.
    Please tell us more about your problem, what kind of operation you did and LSWS did not restart to apply the configuration change.
  9. javii

    javii Member


    On my installation Plesk never restarts LSWS if you use wrapper. No matter what you try to do, create a new subscription, modify an existing one, etc... and I receive an email from Plesk telling me it cannot restart webserver (I suppose it is trying to restart Apache and 80 port is already used by LSWS).

    I'm using Centos 5.5 x86_64 and LSWS Enterprise (I purchased the license yesterday).

    Any idea?
  10. mistwang

    mistwang LiteSpeed Staff

    We tested plesk 10.3 on centos 5.
    Maybe we need to take a look at your server if you do not mind send us a temp root access. you can create ticket under bug report department.
  11. mistwang

    mistwang LiteSpeed Staff

    tested adding a new subscription in our plesk 10 test server, also works fine.
  12. javii

    javii Member

    Ok, I have send you the access details to bug department. Hope you can solve it.

    Thank you, best regards.
  13. mistwang

    mistwang LiteSpeed Staff

    Figured it out, it is due to Apache worker MPM is used.
    edit /etc/sysconfig/httpd

    comment out

    it works properly now.
  14. javii

    javii Member

    Thank you :)

Share This Page