[solved] no custom 404 page ONLY in root of virtual host

Discussion in 'Install/Configuration' started by MPI, Nov 5, 2011.

  1. MPI

    MPI Member

    attempting to browse: /user/public_html/fake_file.php
    returns "Page not found";

    attempting to browse anything in a subdir: /user/public_html/*/fake_file.php
    returns stock 404 error:
    now if I add a custom 404 page through the GUI (under the virtual host in discussion), then all missing URLs return "Page not found" (not my custom404.html page)

    note: not only that, but after adding a custom 404 error page, my pre-existing custom 403 page gets corrupted/buggy.

    p.s. this is a fresh litespeed install, meaning no apache configs are being used.

    Please advise.
    Last edited by a moderator: Nov 8, 2011
  2. MPI

    MPI Member


    only temporary workaround I've come up with so far is to redirect all missing pages with a 410 flag...then setting up a custom 410 error message through the litespeed GUI.

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule .? /error.htm [NC,L,R=410]
    it seems the gui can create custom pages for all error codes EXCEPT 404...what gives??
  3. MPI

    MPI Member

    nvmnd, PROBLEM SOLVED!

    there is an incompatibility between litespeed & vbseo's rewrite rules.
    ...as soon as i disable vbseo, custom 404 pages work as expected.

    turns out vbseo has it's own custom 404 page under it's control panel > general options > 404 page.

    for anyone reading this: note that in addition to the above, you still still have a custom 404 page setup through litespeed control panel which will be used for all sub-directories.
    Last edited: Nov 8, 2011

Share This Page