[solved] PHP config not loading.....

Discussion in 'Install/Configuration' started by bangsters, Jan 4, 2012.

  1. bangsters

    bangsters Well-Known Member

    Hi. Everything seems to be working fine, however, in the PHP info, it says there is no loaded config file. And what's weirder is it says none is loaded even if the php.ini file location is clearly defined, and the file actually exists.

    [root@node1 fcgi-bin]# pwd
    [root@node1 fcgi-bin]# ./lsphp5 -i | grep Configuration
    Configuration File (php.ini) Path => /etc/conf/php/5.2.17/php.ini
    Loaded Configuration File => (none)
    [root@node1 fcgi-bin]#
    [root@node1 fcgi-bin]# cd /etc/conf/php/5.2.17
    [root@node1 5.2.17]# ls
    [root@node1 5.2.17]#

    So how come it's not being loaded? Please advice.

    Last edited by a moderator: Jan 6, 2012
  2. NiteWave

    NiteWave Administrator

    this is wrong, should be
    Configuration File (php.ini) Path => /etc/conf/php/5.2.17

    so to make it work without rebuilding lsphp5,
    #cd /etc/conf/php/5.2.17
    #mv php.ini php.ini.save
    #mkdir php.ini
    #mv php.ini.save php.ini/
  3. bangsters

    bangsters Well-Known Member

    Thanks!! That fixed it. I also replaced lsphp and /usr/bin/lsphp and /usr/bin/php with lsphp-5.2.17. now everything works fine.


Share This Page