[solved] php.ini on Plesk 10 Probleem!

Discussion in 'PHP' started by flowcubano, Jul 7, 2011.

  1. flowcubano

    flowcubano Member


    I have probleem with the php.ini

    I have Compile php 5.1.6 to PHP 5.3.6 with LSAPI.
    With the admin webserver - Compile PHP.

    I have place the php.ini on /usr/local/lsws/lsphp5/lib/php.ini

    But when I go to upgrade wordpress it say that I have php 5.1.6
    And my php page info show php 5.1.6 to

    I have try to place the php.ini on /usr/local/lsws/php/php.ini

    but it not working I get the same probleem.

    How can I fix it?

    Last edited by a moderator: Jul 8, 2011
  2. webizen

    webizen Well-Known Member

    Once PHP compiled via LSWS Admin Console, LSWS needs restart to make the new PHP effective. Also, make sure LSWS is running on port 80 (instead of Apache).

    To verify whether and/or which php.ini is in use, do the followings from command line:
    Last edited: Jul 7, 2011
  3. flowcubano

    flowcubano Member

    I have restart it and it running on port 80 ( httpd is offline)

    When I run the command I get this:

    And still not working!

    On "External app" command line I have this: $SERVER_ROOT/fcgi-bin/lsphp5

    You know other solution?

  4. webizen

    webizen Well-Known Member

    check /usr/local/lsws/lsphp5/lib/php.ini and make sure you have an entry "date.timezone='Europe/Berlin'" in there.

    run '/usr/local/lsws/fcgi-bin/lsphp5 -v' from command line to see which version is running at. also, create a simple phpinfo page with the following to verify from browser
    <?php phpinfo(); ?>
  5. flowcubano

    flowcubano Member

    I have fix the timezone!

    [root@eu ~]# /usr/local/lsws/fcgi-bin/lsphp5 -v
    PHP 5.3.6 (litespeed) (built: Jul 8 2011 00:20:56)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies

    I have restart litespeed but still not working!
  6. webizen

    webizen Well-Known Member

    Are you sure Apache is stopped? The server signature is still Apache from below. Is this the server in question?

  7. flowcubano

    flowcubano Member

    oky thanks it work now!

    But I get now this error en my website: Error establishing a database connection

    I have read that I have to : compile PHP mysql module and set correct mysql socket path

    But I don't not know how to do that kan you tell my how I can do that?

  8. flowcubano

    flowcubano Member

    I have update the mysql.default_socket on my php.ini to te corect mysql socket but it still don't working.

    I have compile php again with this: ( '--with-mysql' )
    But I get this error:
  9. flowcubano

    flowcubano Member

    Hello I have fix the probleem!

    I have use this to compile php: --with-mysql=/usr/bin/ --with-libdir=lib64

    Thank You For The Support!!!

Share This Page