[Solved] Problem on subdomain

Discussion in 'General' started by katana123, Apr 9, 2012.

  1. katana123

    katana123 Member


    We have a problem installing program on subdomain.
    When we tried to install program call flatpress.org (for blog).
    LiteSpeed web server is installing the file ownership as apache instead of UID/GID of that user account.
    It is only happen for subdomain name which we are creating it from PLESK control panel 8.6.
    If we are installing it on the primary domain, the file ownership is correct.
    It is installing using its own UID/GID.

    We are running the latest version of
    LiteSpeed Web Server 4.1.12 Ent

    Can you please fix this issue?
  2. webizen

    webizen Well-Known Member

  3. katana123

    katana123 Member

    Yes, untar it.
    chmod 777 fp-content
    and access the site http://subdomain/flatpress
    Just follow the setup step by step.

    You will see the file inside the fp-content after you run setup. the owner of the directory will be apache:apache
  4. webizen

    webizen Well-Known Member

    can not replicate the issue in our lab. switch to 4.1.11 and see if the issue still remains or pm temporary ssh root access for us to look into further.
  5. katana123

    katana123 Member

    I was using the version 4.1.11 before, it was the same problem.
    We tried to upgrade it to version 4.1.12 and the problem is still the same.
  6. katana123

    katana123 Member

    Problem solved.

    Look like the problem is with PLESK 8.6 when it create the subdomain, it did not create SuexecUserGroup.

    In order to solve this problem, make sure that you Marked hosting feature for: PHP & CGI

    CGI will add SuexecUserGroup to your httpd.include.

    Thank you webizen for your support.
  7. webizen

    webizen Well-Known Member

    Thanks for katana123's sharing!

Share This Page