[Solved] Static images randomly failing

Discussion in 'General' started by Morgon, Apr 19, 2012.

  1. Morgon

    Morgon Member

    Good afternoon,

    I'm configuring a new install of LSWS 4.1.12 and I'm having some trouble with some static content. For pages with a number of static resources (like a category page of an eCommerce site), an image or two will randomly not load.

    In Chrome, it reports this simply as "(failed)" in the Network viewer.
    In Firefox, it displays part of the image that it downloaded, and reports "image is corrupt or truncated" in Firebug.

    It doesn't seem to be any sort of per-connection limits, since transmission is happening; they're just.... stopping. What's interesting to me is that for the most part, they seem to be stopping on common byte sizes: 4096 and 8192.
    I don't know if that's useful information.

    Also I've only seen it happen with images. I don't know if that has anything to do with where in the DOM they're located (the top) whereas the images that fail are generally in the second half of requests for a page.

    There are no logs being generated anywhere that I've found, so it's not something I have any current insight into. Anyone have any configuration settings I may be able to try?

    Last edited: Apr 19, 2012
  2. webizen

    webizen Well-Known Member

    are these static files served straight or via php ?

    access log (i.e. /usr/local/lsws/logs/access.log) should show if the images files are served
  3. Morgon

    Morgon Member

    Thanks for the response.

    a) They are static, being served directly by the filesystem.
    b) They are being served. See the following (sanitized) log: - - [19/Apr/2012:13:07:06 -0500] "GET /media/catalog/product/cache/1/small_image/165x/9df78eab33525d08d6e5fb8d27136e95/m/y/my_image.png HTTP/1.1" 200 4096 "[referer]" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.162 Safari/535.19"

    As you can see, it only served 4096 bytes.

    The file itself is 19059 bytes.
  4. webizen

    webizen Well-Known Member

    how about request the static file directly (not from the base page)? still get partial content?
  5. NiteWave

    NiteWave Administrator

    and how about with lsws 4.1.11 ?
  6. Morgon

    Morgon Member

    No, I always get the full file on direct access.

    And just to be clear, it's only one or two (out of anywhere between 30 - 40) that only has partial content on a page load, not every image. Hitting a single file directly seems to be just fine. Though maybe I can set up ab to try to hit the same image repeatedly and see if any thread gets a different content size.

    If I 'downgrade' to 4.1.11, would I be able to keep my settings, or would I have to go through re-compiling PHP and setting up my vhosts?
  7. NiteWave

    NiteWave Administrator

    all your settings is there, no need re-compile PHP etc, and your 4.1.12 still there.

    switching between lsws versions is just one button click:
    lsws admin console->Actions->Version Manager->SwitchTo
  8. Morgon

    Morgon Member

    Great, thank you. I was able to find the download for 4.1.11, installed and switched to it (didn't have it previously).

    In any case, it seems your suspicion may be correct - I spent a good 15 minutes clicking around the same pages as before, but not seeing any of the same image truncation issues as I did with 4.1.12.
    Out of curiosity, does that indicate an issue with LSWS, or my environment?
  9. Sparaker

    Sparaker Member

    This is an issue with 4.1.12

    I am seeing this also on my websites. It seems a bug in LSWS itself. Please fix this ASAP. This is a rather urgent bug that needs attention.

    I also get random images being truncated, upon refresh most of them load just fine.
  10. webizen

    webizen Well-Known Member

    to help troubleshoot, check server access log for the image in question and verify if it was served partial and fully served on browser refresh.
  11. Sparaker

    Sparaker Member

    I did a force reinstall already and the issue still persists. I checked the log files and the file is actually served partially for some unknown reason. This is a static image. I have exactly the same problem that the thread starter has. I am thinking it must be a bug that needs fixing, oh btw i am on Cpanel/WHM
  12. mistwang

    mistwang LiteSpeed Staff

    uploaded a new build of 4.1.12, the bug should have been fixed now.
  13. Sparaker

    Sparaker Member

    How do you check for build number ?
  14. NiteWave

    NiteWave Administrator

    check the package's time stamp
  15. jdeg

    jdeg Active Member

    I was having the same problem. Switching to 4.1.11 seems to have solved the problem for now.
  16. NiteWave

    NiteWave Administrator

    please do a force-reinstall on 4.1.12:
    admin console->Actions->Version Manager
  17. jdeg

    jdeg Active Member

    Thanks, that worked too.

Share This Page