[solved] SuExec Daemon + CageFS = Poor Performance

Discussion in 'General' started by bettinz, Nov 29, 2012.

  1. bettinz

    bettinz Well-Known Member

    Hello, I've a problem, and I ask your help to find the cause:

    I've Litespeed 4.2.1 LSAPI 6.1, Cloudlinux 6.3 with CageFS.

    If I enable the SuExec Daemon with this settings in external app:

    Auto Start : Through CGI Daemon

    and Run On Start Up: suEXEC Daemon

    I can see poor performance. I don't know why, but the cost of first open, is high.

    With the same settings (tuning, ext app, etc), but with:

    Autostart: Yes
    and Run On Start Up: No

    I can see old speedy Litespeed. Why?

    Last edited by a moderator: Feb 3, 2013
  2. webizen

    webizen Well-Known Member

    how about with cagefs disable?
  3. bettinz

    bettinz Well-Known Member

    If I disable CageFS, everything works speedy :confused:
  4. mistwang

    mistwang LiteSpeed Staff

    Please email to bug@litespeed... or PM us temp root access, we can take a look.
  5. NiteWave

    NiteWave Administrator

    looks no reply from bettinz.
    it's best bettinz can update this post.

    that's no known performance issue so far regarding suExec Daemon + CaseFS

    but phpSeletor which working with apache not working with litespeed yet -- CloudLinux and litespeed will co-operate to work on this.

    one known poor performance issue is, set Cage limit too low, after adjust the limit, back to normal.
    Last edited: Feb 2, 2013
  6. bettinz

    bettinz Well-Known Member

    Hello :) in my case, the problem is solved by setting an higher value of limits. By the nature of limits, websites are a bit slower, but if website in the past can use 100% of cpu, now it's limited to 25%, so it's normal. In my case, another problem was database optimization.
  7. NiteWave

    NiteWave Administrator

    Thanks for the update. will mark [solved]

Share This Page