[solved] Update PHP 4 to 5

Discussion in 'Install/Configuration' started by alaminour, Dec 15, 2012.

  1. alaminour

    alaminour Member

    Hi, I install LightSpeed free edition on Rackspace VPS.

    But can't update PHP.
    **ERROR** Could not configure PHP build
    Please advice.
    Last edited by a moderator: Dec 16, 2012
  2. NiteWave

    NiteWave Administrator

    the URL is ok which is php 4.4.9
    where did you see the error message ? please provide more info.
  3. alaminour

    alaminour Member

    I tried to "Compile PHP with LSAPI" through admin panel, then this error coming.

    Step 4 : Monitoring build process

    **MAIN_STATUS** retrieved from /usr/local/lsws/phpbuild/buildphp_1355551832.1.progress
    Start building PHP 5.4.9 with LSAPI
    Configuring PHP build (2-3 minutes)
    **ERROR** Could not configure PHP build


    I am using CentOS 5.8.
  4. NiteWave

    NiteWave Administrator

    please scroll down the end of the build window, the detail error message is there. you just saw the summary error message at top of the window.
  5. alaminour

    alaminour Member

  6. NiteWave

    NiteWave Administrator

  7. alaminour

    alaminour Member

    It works

    Thanks a lot, Its worked with flowing command :

    yum install libxml2-devel.x86_64 openssl-devel.x86_64 bzip2-devel.x86_64 libcurl-devel.x86_64 db4-devel.x86_64 \
    libjpeg-devel.x86_64 libpng-devel.x86_64 libXpm-devel.x86_64 freetype-devel.x86_64 gmp-devel.x86_64 \
    libc-client-devel.x86_64 openldap-devel.x86_64 libmcrypt-devel.x86_64 mhash-devel.x86_64 freetds-devel.x86_64 \
    zlib-devel.x86_64 mysql-devel.x86_64 ncurses-devel.x86_64 pcre-devel.x86_64 unixODBC-devel.x86_64 postgresql-devel.x86_64 \
    sqlite-devel.x86_64 aspell-devel.x86_64 readline-devel.x86_64 recode-devel.x86_64 net-snmp-devel.x86_64 \
    libtidy-devel.x86_64 libxslt-devel.x86_64 t1lib-devel.x86_64


Share This Page