[solved] Use different PHP versions on same server


Well-Known Member

I have compiled both PHP 5.2 and 5.3 binaries using the LSWS console and followed the instructions here:

I have created the external applications and configured the script handlers. However, adding the AddHandler/AddType directives to .htaccess have no effect. The default handler is set up with PHP 5.3 and I want to force 5.2 through .htaccess.

I have tried the following variations:

AddHandler application/x-httpd-php52 php
AddHandler application/x-httpd-php52 .php
AddType application/x-httpd-php52 php
AddType application/x-httpd-php52 .php
A script handler with "php52" suffix exists, which uses the external app. which points to the PHP 5.2 binary. I tripple checked everything and it should be correct.

When I load the PHP script it uses PHP 5.3 no matter what. I monitored the sockets, and I do see that the PHP 5.2 socket (uds://tmp/lshttpd/lsphp52.sock) is created as well.

The strange thing, though, is that I have the exact same setup on another server and it works fine.

Any thoughts?
Last edited by a moderator:


Well-Known Member
Actually, after some more testing it does work. I was testing with a php file in /usr/local/apache/htdocs (this is a cPanel server).

For some reason, LiteSpeed would not pick up the .htaccess changes from this location, but when ran from a user directory (/home/<user>/public_html) it seems to work fine.

Thanks anyway.