SSL installation // beginning process

Discussion in 'Install/Configuration' started by whey, Dec 15, 2008.

  1. whey

    whey Member

    My SSL provider just came back to me and now i need to generate a csr code. I tried the following:

    openssl req -new -key server.key -out server.csr

    And nothing happened so I installed openssl 0.9.8i and still nothing, it comes back with:

    Error opening Private Key server.key                                                                
    5811:error:02001002:system library:fopen:No such file or directory:bss_file.c:352:fopen('server.key'
    5811:error:20074002:BIO routines:FILE_CTRL:system lib:bss_file.c:354:                               
    unable to load Private Key    
    any ideas as to what to do? thanks.
  2. whey

    whey Member

    Got that figured out, was putting the file in the wrong directory.

    however now i got the domainname.key and domainname.csr put in /home/userx for now. where do these files need to placed to work in lsws?

  3. mistwang

    mistwang LiteSpeed Staff

    We usually put it in /opt/lsws/conf/cert
  4. whey

    whey Member

    Got the crt from my SSL provider but now I am getting a ssl_error_no_cypher_overlap error:

    I have both the private and cert path provided in a new listener with a 128 bit encyrption on ssl v3.0,

    Any solutions?

  5. mistwang

    mistwang LiteSpeed Staff

    check TLS and encryption level "HIGH"
  6. whey

    whey Member

    thanks, works now :)

  7. whey

    whey Member

    is there a way to set all logins thought the litespeed cp to ssl? I thought I seen it around in the manuel can't seem to now.
  8. mistwang

    mistwang LiteSpeed Staff

    You need to change the admin listener configuration.
  9. anewday

    anewday Moderator

Share This Page