SSL on FreeBSD 6.0

Discussion in 'Bug Reports' started by inspirix, Oct 22, 2006.

  1. inspirix

    inspirix Active Member

    Ive been able to get SSL working on a test server running CentOS, however when I try to do the same configuration on my production FreeBSD 6.0 server, I run into problems. As soon as I put the SSL configuration in place and click Graceful restart, the server never comes back up. The logs do not show any errors and the process seems to immediately die. I am running 2.2.2 Standard. In order to get the server back online, I have to manually remove the listener section for SSL from http_config.xml and the /usr/local/lsws/bin/lswsctrl restart.

    Is this more likely to be related to missing dependencies? (I have installed openssl)

    Or more likely to be a limitation of the freebsd version?

    Also, 2.2.3 is out but on my FreeBSD box I tried to do the upgrade and the server never came back online as well, so I removed the symlink to lshttpd.2.2.3 and put it back to lshttpd.2.2.2. Everything works again, but hopefully that was the only needed change to really put it back to 2.2.2.

    It _seems_ that it would just be better to stick to linux (centos in my case) servers as they seems to be best supported. Would you agree this would be the best approach to minimize problems moving forward?
  2. xing

    xing LiteSpeed Staff

Share This Page