symlnk problem - upgrading from 3.3.23

Discussion in 'General' started by jrmarino, Jan 1, 2010.

  1. jrmarino

    jrmarino Well-Known Member

    Today I tried upgrading from 3.2.23-std.

    There were some problems - first 4.0.11 wasn't downloaded automatically (404 issue). I finally downloaded 4.0.12 manually and somehow got litespeed to recognize it.

    When 4.0.12 became active, it would not follow the symlinks on one of my virtual hosts. I verified that the setting was correct, but I still got 403 (forbidden) errors no matter what I did.

    It's also very hard to get back to 3.3.23. The "switch to" doesn't really work. I had to log out, log in, stop and restart the server manually several times until it finally worked. I did this three times, and it was difficult all three times.

    Do the Litespeed folks know what could be the problem? I've been running 3.3.23 without any problems for over a year so I don't really have need to upgrade but I wanted to see what version 4 brings.
  2. mistwang

    mistwang LiteSpeed Staff

    Please check error log for the reason of 403 error. Should be a permission/ownership issue.
  3. jrmarino

    jrmarino Well-Known Member

    Can you elaborate? I specifically checked that the symlink option did not require matching owners.

    More over, the symlink and the symlinked directory ownership match on one directory, and the webservd is the group owner of the second directory (same user). Neither works.

    I just checked my log, I have been getting 10MB per day since I reverted back to 3.3.23

    Sothing about lscgid failed to open secret file: .cgid.sock.068.
    secret not set properly.

    How do I fix this?
  4. jrmarino

    jrmarino Well-Known Member

    I see a new directory called cgid with a subdirectory called secret in it. Is this something that 4.0.12 created and now 3.3.23 is all confused and misconfigured with this cgid socket?
  5. jrmarino

    jrmarino Well-Known Member

    to be clear, the error log is filling up once per second.
    It's something called lscgid looking for the socket files in {root}/admin/conf/secret directory but the socket files are being created in the {root}/admin/conf directory.

    How do I tell lscgid where to find the socket files?

    What a nightmare this upgrade has been.
  6. jrmarino

    jrmarino Well-Known Member

    I just noticed bin/httpd is symlinked to lscgid.4.0.12
    I'm going to delete that symlink manually and recreate it pointing to ./lscgid.3.3.23

    I'll say this support board isn't monitored frequently enough in my opinion.
  7. jrmarino

    jrmarino Well-Known Member

    That fixed it. I'm now back to 3.3.23 without runaway logs.

Share This Page