Trying to debug dispatch.lsapi

Discussion in 'Ruby/Rails' started by solars, May 21, 2008.

  1. solars

    solars Member

    Hey again,

    dispatch.lsapi suddenly gets killed on the first request on one app, this might be due to path changes in the framework and the LS environment.
    Everything runs fine on script/server, mongrel, thin and mod_rails.

    I don't get any meaningful error messages (litespeed only reports runaway process) so I tried it with strace:

    Here is the (hopefully) important output:

    can anyone please tell me whats going wrong here? I can't really understand it ....
    Last edited: May 21, 2008
  2. mistwang

    mistwang LiteSpeed Staff

    The strace output does not show anything useful.
    You have to strace it when it is serving a problem request.
  3. mistwang

    mistwang LiteSpeed Staff

  4. solars

    solars Member

    sorry, yeah that was the wrong snippet obviously.

    I finally found the bug and fixed it, it's quite hard to debug though
  5. Xorlev

    Xorlev Well-Known Member

    What was the bug?

Share This Page