Unable to login to the adminpanel

Discussion in 'Install/Configuration' started by Falcon, Jul 9, 2005.

  1. Falcon

    Falcon Member


    I'm using your latest release, 2.0.7 (lsws-2.0.7-std-i386-linux.tar.gz) for my linux 2.6 i386 machine, I followed the docs/install and everything works fine except the authorization when I'm supposed to login, it never accepts me and I have absolutley no clue why.

    A friend of mine is also using your server, and he has doublechecked that I am not doing anything wrong in the installation-process (I download it to my useraccount, which is a non-root acc, decompresse it, run install, and connect to the www-admin-page).

    It's not like I'm using a very sofisticated password nor username (login: admin pass: 123456) either.

    Whats else.. Hmm, yeah, the normal (non-admin) site works fine, and both "Hello World from CGI script", "phpinfo.php", "missing page", "Password protected content" and "blocked area" works.

    I have also tried to use the admpass.sh (and even restarted the server afterwards), but no success there either.

    Thanks in advance!
  2. mistwang

    mistwang LiteSpeed Staff

    Please check the password file, at lsws/admin/conf/htpasswd, see if the password file is in good shape. Also, be careful with file permission.

    Is lsws installed as your non-root account?
  3. Falcon

    Falcon Member

    That certainly did the trick, or, or atleast your attention did. It seems like the admpasswd.sh isn't really stable, because it didn't gave me any errormsges when I used it. However, I changed the password with the help of htpasswd, (which I figured generated the same types of passwords), and then it worked.

    1. htpasswd -n admin
    2. <inputs password twice>
    3. Copy the result to the "lsws/admin/conf/htpasswd"-file.
    4. Done.

    Thanks alot mistwang!
  4. mistwang

    mistwang LiteSpeed Staff

    You are welcome! :)

    Usually, the admpass.sh works fine, but it may fail under certain environment.
    Would you mind showing us the content of the htpasswd file generated by admpass.sh, it can help us fixing the bug.

  5. Falcon

    Falcon Member

    Sure! I'll do anything I can to help such a great webserver as yours.
    Here's how my htpasswd looks like:
  6. mistwang

    mistwang LiteSpeed Staff

    Thank you, Falcon, :)

    I might be wrong, but I think that's your current password file generated by htpasswd. What I real interested in is the content of the password file created by adminpass.sh. Sorry for the confusion.

    Can you help with that?


  7. Falcon

    Falcon Member


    Sorry for this big time difference, I've been on a holiday and haven't been online since. However, I noticed now that it wasn't your litespeed webserver to blame, I had myself not set the proper permissions (I had 600) on the htpasswd-file, and as a result, the user running the webserver could not read it. I doubt that you'd still want the text that is inside after hearing that, but if you still do, please repeat. :D

    // Falcon.
  8. mistwang

    mistwang LiteSpeed Staff

    Ok, I see.


Share This Page