updgrade to php5 problem

Discussion in 'Install/Configuration' started by karloff, Jul 16, 2008.

  1. mistwang

    mistwang LiteSpeed Staff

    add php configuration option "--with-png-dir=/opt/local".
  2. wagonlips

    wagonlips Member

    Thank you! I did as you said and it was happy, for a second.
    Next the configuration script asked for the mysql_config location which I found and added like so:
    Then it wanted the location of mysql.sock and I added this:
    "Surely, I am home free now," I thought to myself. But then...
    configure: error: Cannot find MySQL header files under yes.
    In this post http://litespeedtech.com/support/forum/showthread.php?t=2200 (you really are prolific), you indicate that the solution is to "install mysql client library devel package." I would like to do that, but I'm having a hard time finding such a thing for this OS X 10.5 (PPC) box. Any ideas?
  3. mistwang

    mistwang LiteSpeed Staff

    You probably have it already, just try
  4. wagonlips

    wagonlips Member

    So I did that, and then some other things, too. I can't remember all the different things I tried, but eventually I got past this.

    At the end of the configuration log I find the message:
    configure: error: freetype.h not found.
    But the file lives here:
    So far, I've tried --with-freetype-dir=/opt/local/include,
    --with-freetype-dir=/opt/local/include/freetype2, and
    and it failed each time.

    So I pulled the freetype call from the list.

    Then I pulled the --with-mysqli bit and it configured!

    But it didn't actually build.

    ld: symbol(s) not found
    collect2: ld returned 1 exit status
    make: *** [sapi/litespeed/php] Error 1
    Here are the parameters I used to get that far:
    "--with-mysql=/usr/local/mysql-5.0.51b-osx10.4-powerpc/ --with-zlib --with-gd --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --enable-magic-quotes --enable-mbstring --with-iconv --with-png-dir=/opt/local --with-config-file-path=/usr/local/mysql-5.0.51b-osx10.4-powerpc/bin --with-mysql-sock=/tmp/mysql.sock --with-jpeg-dir=/opt/local/lib"
  5. wagonlips

    wagonlips Member

    I sort of solved this by using a CentOS Linux box instead. OS X is nice and all, but presented too many configuration hoops for me to jump through. With Yum I was able to easily install all of the libraries that building PHP5 required, had it up and running in a comparably short time.

    Thank you very much for the help! The stuff I learned while trying to build it under OS X definitely made installing on Linux that much easier.

Share This Page