upgraded from php 5.3 to php 5.4, mysql now not found

Discussion in 'Install/Configuration' started by bangsters, Jun 8, 2014.

  1. bangsters

    bangsters Well-Known Member

    Hello. We have updated our php from 5.3 to 5.4. After completing the update, all sites with mysql databases are no longer working. We have compiled php with '--with-mysql' but still not working.

    Any suggestions?
     
  2. NiteWave

    NiteWave Administrator

    any difference of compile option between 5.3 and 5.4 ?
    can check it by
    /usr/local/lsws/fcgi-bin/lsphp-5.3.x -i |head
    /usr/local/lsws/fcgi-bin/lsphp-5.4.x -i |head
     
  3. bangsters

    bangsters Well-Known Member

    sorry for late reply. had other issues on the network that i had to take care of so I kinda put this aside.

    anyway, i just used the same compile option with 5.3 and 5.4. It has '--with-mysql' option
     
  4. bangsters

    bangsters Well-Known Member

    Looks like I'm stuck with this issue. I already tried the following:

    --with-mysql -- compiled but no databases load when sites are opened, looks like mysqlnd is not working for 5.4 as phpinfo shows mysql is loaded with mysqlnd

    --with-mysql=/usr/bin/mysql_config -- will not compile, error shows up saying it's no longer bundled
    --with-mysql=/usr --compiled but still not working..

    I tried removing --with-mysql during compile, and added extension=/usr/lib64/php/modules/mysql.so in php.ini, still wouldn't work.

    Am I missing anything? When I go back to 5.3.28 everything works fine, with 5.4 it doesn't work. Below is the php options I use based on what was suggested by some. Maybe something below is what's causing mysql to fail?? Any advice?

    '--with-config-file-path=/etc' '--sysconfdir=/etc/conf/php/5.4.29' '--with-config-file-path=/etc/conf/php/5.4.29' '--with-config-file-scan-dir=/etc/conf/php/5.4.29/php.d' '--with-litespeed' '--with-libdir=lib64' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' '--with-t1lib=/usr' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--with-kerberos' '--enable-ucd-snmp-hack' '--enable-shmop' '--enable-calendar' '--without-mime-magic' '--without-sqlite' '--with-libxml-dir=/usr' '--enable-xml' '--with-system-tzdata' '--enable-force-cgi-redirect' '--enable-pcntl' '--with-imap=shared' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbregex' '--with-ncurses=shared' '--with-gd=shared' '--enable-bcmath=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--with-mysql' '--with-mysqli=shared,/usr/bin/mysql_config' '--enable-dom=shared' '--with-pgsql=shared' '--enable-wddx=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--with-curl=shared,/usr' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,/usr' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--enable-json=shared' '--enable-zip=shared' '--with-readline' '--with-ssh2' '--enable-dbase=shared' '--with-pspell=shared' '--with-mcrypt=shared,/usr' '--with-mhash=shared,/usr' '--with-tidy=shared,/usr' '--enable-sysvmsg=shared' '--enable-sysvshm=shared' '--enable-sysvsem=shared' '--enable-posix=shared' '--with-unixODBC=shared,/usr' '--with-curl'
     
  5. NiteWave

    NiteWave Administrator

Share This Page