Upgrading PHP LSAPI

Discussion in 'Install/Configuration' started by kuts, Apr 19, 2008.

  1. kuts

    kuts Well-Known Member

    So there's a new version of PHP LSAPI and LiteSpeed 3.3.10

    I already upgraded to 3.3.10. Will recompiling PHP via LS admin panel upgrade to the latest version of PHP LSAPI?
  2. anewday

    anewday Moderator

    Yeah it should.
  3. kuts

    kuts Well-Known Member

    how do you determine the PHP LSAPI version you're currently using anyway?
  4. mistwang

    mistwang LiteSpeed Staff

    Not possible now, will add a version number in the phpinfo page.
    Anyway, the web console will always use the latest version.
  5. kuts

    kuts Well-Known Member


    just to confirm, recompiling the php will update the lsapi to the latest version?
  6. mistwang

    mistwang LiteSpeed Staff

    Yes, that's correct.
  7. brrr

    brrr Well-Known Member


    Can I suggest that this info (ie 'recompiling PHP will update the LSAPI to the latest version') was in the FAQ or in the LSWS/LSAPI readme.

    I was puzzling over this myself.
  8. brrr

    brrr Well-Known Member

    I just tried compiling PHP 4.4.8 on LSWS Std 3.3.10, running on CentOS 4.6 on a OpenVZ VPS.

    It failed at step 1 and I got the following error message:

    Both wget and curl are however available on the server and LSWS has never had any problems downloading updates etc before.

    I tried the PHP 4.4.8 upgrade using the standard configure switches and I also ticked the Suhosin box and the eAccelerator box.

  9. brrr

    brrr Well-Known Member

    OK, I reset the permissions on wget and gcc to 0755 as suggested elsewhere in the forum.

    Now wget works and the php sources etc successfully download.

    Now however buildconf gets some sort of permission errors on /dev/null or something and the upgrade aborts.

    Here is the last part of the relevant install log:
    Buildconf however already has permissions set as 0755.

    Any suggestions?
  10. mistwang

    mistwang LiteSpeed Staff

    /dev/null has permission problem not buildconf script.

Share This Page