URGENT! Swap Location/Removal

Discussion in 'General' started by iUnknown, Apr 14, 2009.

  1. iUnknown

    iUnknown Active Member


    Litespeed is causing my server to constantly have server loads going extremely high. I checked the swapping directory and it is set to what I have previously set it to (/opt/lsws/swap) and I started deleting some files in /tmp/lshttpd/swap to free up some space in /tmp and Litespeed has made the server load 80+. What should I do?

    Thanks very much.
  2. iUnknown

    iUnknown Active Member

    Sorry, it is a major coincidence that when I started doing this we went under DDoS. What I've said has nothing to do with the high load. I will try and sort that out.
  3. iUnknown

    iUnknown Active Member

    I was wrong, there is a bad issue with litespeed. It is going crazy and using up all of my processing power now... That's all I can really say, it's shot the server load up and the %ni in top has shot up too, with litespeed being the cause.
  4. iUnknown

    iUnknown Active Member

    It's running as priority 1 when in settings it's 0? I think that may be the issue?
  5. mistwang

    mistwang LiteSpeed Staff

    For this kind situation, it is more likely PHP processes gets into a infinite loop for some reason.

    I would just kill those PHP processes, see if it comes back.
    Restart LSWS may get those PHP processes killed as well.

    If it does come back, try "strace" the process using too much CPU, see if you can find out anything.

    CPU cycles used by processes with priority other "0" will be counted towards %ni, your problem is that PHP were using too much CPU, not the process priority.
  6. iUnknown

    iUnknown Active Member

    The processes would get killed but they kept coming back when litespeed started. Changing my setting for max keep alive requests from 1000 to 10000 seems to have resolved the problem...
  7. iUnknown

    iUnknown Active Member

    This has not solved the problem, it just seems to happen at peak hours (based in the UK). I've tried reinstalling litespeed and it hasn't helped.
  8. anewday

    anewday Moderator

    Better ask mistwang to take a look in your server.

Share This Page