vbulletin mods not working

Discussion in 'General' started by Robert, May 15, 2010.

  1. Robert

    Robert Member

    I recently switched to URLJet as my web host. They run Litespeed. From the moment I joined them these vbulletin mods do not work anymore.

    Please note: the previous web host had Apache.

    This is what makes me think it must be a server setting.

    It'll post the thread to my site. But, it will not tweet to twitter or shorten the URL on my bit.ly account.

    Last edited: May 15, 2010
  2. NiteWave

    NiteWave Administrator

    can you specify which vbulletin mods? maybe other people happen to have same experience and know the solution.
  3. Robert

    Robert Member

    I can't post images or links until I get to 5 posts but here are the names.

    vbulletin to Twitter, live tweets of new threads


  4. mistwang

    mistwang LiteSpeed Staff

    It might be a missing PHP module or something, you should contact your hosting company to look into the problem.
  5. Robert

    Robert Member

    Would it be possible for you to be a little more specific or shall I just say "it must be a missing PHP module or something."

    The reason I ask is that my web host is aware of my problem yet have been able to provide me exactly zero guidance in this situation.

    Thanks. :)
  6. brrr

    brrr Well-Known Member

    I think mistwang may be suggesting that the installation of PHP your host is providing may have been compiled without some of the PHP modules your code may need, or may have those modules disabled in the configuration of PHP that you are using.

    What are the technical requirements for those vbulletin mods? Usually the authors will say something like 'this modification requires MySQL v4+ and PHP v5 or above, with blah blah GD, mailparse, blahblah support'.

    Find that out, then look into the phpinfo output for your server and see if the PHP installation you are running has the bits you need listed in there.
  7. Robert

    Robert Member


    I know I need # cURL library compiled into my php and
    # JSON support compiled into my php

    and they said they do.
  8. NiteWave

    NiteWave Administrator

    if there is missing module, you can check error_log, see if log entry like
    [STDERR] PHP Fatal error:  Call to undefined function xxx() in /home/xxx/xxx.php on line xxxx
    is there. Then search the undefined function name to determine which php module is missing.
  9. Robert

    Robert Member

    Here are the bottom 15 lines or so from my error_log file on my server. Can you give me a little insight to these errors before I present them to my web host.

    As I mentioned last night they have provided zero help to rectify this problem.

    As you can see one of the errors involves twitter.php, a file that I need for this mod.

    Thank you.

    [05-May-2010 10:42:15] PHP Parse error: syntax error, unexpected '!', expecting ',' or ';' in /home/xxxxxxx/public_html/talkclassicrock.com/forums/includes/twitter.php on line 73
    [05-May-2010 10:46:40] PHP Parse error: syntax error, unexpected T_STRING, expecting T_VARIABLE in /home/xxxxxxx/public_html/talkclassicrock.com/forums/includes/twitter.php on line 73
    [06-May-2010 14:31:47] PHP Fatal error: Cannot redeclare class TwitterException in /home/xxxxxxx/public_html/talkclassicrock.com/forums/includes/twitter.php on line 1872
    [12-May-2010 11:09:07] PHP Parse error: syntax error, unexpected T_VARIABLE in /home/xxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273) : eval()'d code on line 7
    [12-May-2010 19:31:50] PHP Parse error: syntax error, unexpected T_VARIABLE in /home/xxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273) : eval()'d code on line 7
    [12-May-2010 21:54:15] PHP Parse error: syntax error, unexpected T_VARIABLE in /home/xxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273) : eval()'d code on line 7
    [13-May-2010 10:03:28] PHP Parse error: syntax error, unexpected T_VARIABLE in /home/xxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273) : eval()'d code on line 7
    [13-May-2010 21:54:29] PHP Parse error: syntax error, unexpected T_VARIABLE in /home/xxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273) : eval()'d code on line 7
  10. brrr

    brrr Well-Known Member

    They seem like simple errors in the php code. Nothing to do with your hosting or litespeed.

    Open up the php scripts (eg twitter.php) in a text editor and see what line 73 looks like. It might be as simple an issue as a file location or path is being referenced in the script that points back to the filesystem structure your old host maintained.

    Or ask the author of the script for some help in debugging those code errors.
  11. Robert

    Robert Member

    Line 73 simply reads -

    private $password;

    I've already spoken to the author of twitter.php and he claims the class works perfectly.
  12. brrr

    brrr Well-Known Member

    Google those exact PHP error responses - that may provide you with some clues about what is going on in the code. And re-examine the way the mod has been installed very carefully.
  13. mistwang

    mistwang LiteSpeed Staff

    Maybe the script requires a higher version of PHP, does not the "private" key word.
  14. Robert

    Robert Member

    Now that I'm allowed to post link and images. Here's the mod in question:


    Here's what I got just before. Mind you my web host does indeed have JSON enabled.
    These are the errors when I run it with bit.ly URL shortening

    { "errorCode": 0, "errorMessage": "", "results": { "http://www.talkclassicrock.com/forums/showthread.php?t=600": { "hash": "94JflJ", "shortCNAMEUrl": "http://bit.ly/a0Ctpx", "shortKeywordUrl": "", "shortUrl": "http://bit.ly/a0Ctpx", "userHash": "a0Ctpx" } }, "statusCode": "OK" }Invalid JSON-response on line 196 in /home/xxxxxxx/public_html/talkclassicrock.com/forums/includes/bitly.php
    #0 /home/xxxxxxx/public_html/talkclassicrock.com/forums/includes/bitly.php(382): Bitly->doCall('shorten', Array)
    #1 /home/xxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273) : eval()'d code(13): Bitly->shorten('http://www.talk...')
    #2 /home/xxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273): eval()
    #3 /home/xxxxxx/public_html/talkclassicrock.com/forums/vbseo.php(1382): require('/home/xxxxxxx/...')
    #4 {main}

    Fatal error: Invalid JSON-response on line 196 in [path]/includes/bitly.php in [path]/vb/vb.php on line 287
    Last edited: May 19, 2010
  15. Robert

    Robert Member

    Here's the errors when I run it with is.gd URL shortening

    /statuses/update.xml Could not authenticate you. Unauthorized on line 229 in /home/xxxxxxx/public_html/talkclassicrock.com/forums/includes/twitter.php
    #0 /home/xxxxxxx/public_html/talkclassicrock.com/forums/includes/twitter.php(648): Twitter->doCall('statuses/update...', Array, true)
    #1 /home/xxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273) : eval()'d code(33): Twitter->updateStatus('test - http://i...')
    #2 /home/xxxxxxxx/public_html/talkclassicrock.com/forums/newthread.php(273): eval()
    #3 /home/xxxxxxxx/public_html/talkclassicrock.com/forums/vbseo.php(1382): require('/home/xxxxxxxx/...')
    #4 {main}
  16. Robert

    Robert Member

    See that first line which contains /statuses/update.xml

    What is that?

    I definetly do not have that file nor the directory "statuses" :confused:
  17. Robert

    Robert Member

    Is there an answer in our future?
  18. mistwang

    mistwang LiteSpeed Staff

    I think /statuses/update.xml is on remote server that twitter.php talking to, it requires authentication.
  19. brrr

    brrr Well-Known Member

    I think you are in the wrong place if you expect all your problems with this 3rd party PHP script to be solved here, especially when it seems pretty clear by now that the issues (eg file includes specified in that script) have nothing to do with Litespeed.
  20. Robert

    Robert Member

    It funny you say that because:

    - The mod authors claim NO responsibility. Their code is working.

    - The twitter.php mod claims NO responsibility. His class works fine.

    Everyone says its the other person's problem yet it doesn't work.

    This mod stopped working the day I joined URLJet. It must be a server setting. But, they can't find a solution either.

Share This Page